Tom 'spot' Callaway (tcallawa(a)redhat.com) said:
> I drafted a proposal for when it is ok to use Conflicts: (almost never):
> Keep in mind that while it is not stated in the Draft, the kernel is
> considered a special case, and I feel strongly that most (if not all) of
> its existing Conflicts: will be approved.
> Fedora Packaging Committee Members should vote via email on this issue,
> as we did not have quorum in the IRC meeting to vote.
My package, foo-game doesn't work when bar is older than 1.2.3.
WRONG: Conflicts: bar < 1.2.3
RIGHT: Requires: bar >= 1.2.3
What about when foo-game doesn't actually require bar?
To be more precise:
$ rpm -q --conflicts initscripts
mkinitrd < 4.0
kernel < 2.6.12
ypbind < 1.6-12
psacct < 6.3.2-12
kbd < 1.06-19
lokkit < 0.50-14
dhclient < 3.0.3-7
tcsh < 6.13-5
glib2 < 2.11.1-2
Some of these can be flipped to requires (kernel, for example, glib2). However,
making initscripts *require* things like ypbind, psacct, dhclient would be
Already covered =>
When you must use Conflicts
If you find yourself in a situation where ... this package cannot
function when another package is installed ... you need to ...