On Fri, 2016-06-17 at 15:37 +0300, Dmitry V. Levin wrote:
On Fri, Jun 10, 2016 at 02:06:43PM +0200, Mark Wielaard wrote:
> +The ideal patch contains a ChangeLog entry and a test case for the
> +bug fixed or feature added. The testsuite (make check) is zero FAIL.
The last sentence looks confusing, could you reword it, please?
I suppose the idea is that testsuite is expected to have zero
Yes. I meant that people that do add new tests should make sure they
PASS (or are skipped). How about replacing that sentence with the
following paragraph explaining the intent:
+The testsuite (make check) is expected to have zero failing tests.
+Do not knowingly add tests that FAIL. If there are architectures or
+configurations where a tests is not supported make sure they are
+skipped instead of failing. Adding "exit 77" in the test shell wrapper
+indicates that a test was SKIPPED.