Change in vdsm[master]: storage: Add logging on filesystem altering operations

nsoffer at redhat.com nsoffer at redhat.com
Tue May 13 07:22:58 UTC 2014


Nir Soffer has posted comments on this change.

Change subject: storage: Add logging on filesystem altering operations
......................................................................


Patch Set 6: Code-Review-1

(1 comment)

I found one case where you added a new variable but you are not using it in the code, so the logic duplication remain. Please fix all instances of this error.

http://gerrit.ovirt.org/#/c/26046/6/vdsm/storage/fileSD.py
File vdsm/storage/fileSD.py:

Line 392:                 self.log.debug("Removing file: %s", volPath)
Line 393:                 self.oop.os.remove(volPath)
Line 394:                 metaFile = volPath + '.meta'
Line 395:                 self.log.debug("Removing file: %s", metaFile)
Line 396:                 self.oop.os.remove(volPath + '.meta')
You added a new variable, but you are not using it in the code, so the same duplicate logic remain.

    self.oop.os.remove(metaFile)
Line 397:                 leaseFile = volPath + '.lease'
Line 398:                 self.log.debug("Removing file: %s", leaseFile)
Line 399:                 self.oop.os.remove(volPath + '.lease')
Line 400:             except OSError:


-- 
To view, visit http://gerrit.ovirt.org/26046
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I3602513af123951f71091c03f799e36ea759aa61
Gerrit-PatchSet: 6
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Xavi Francisco <xfrancis at redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Nir Soffer <nsoffer at redhat.com>
Gerrit-Reviewer: Xavi Francisco <xfrancis at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list