[SSSD] [PATCH] sss_cache: support for subdomains

Michal Židek mzidek at redhat.com
Fri Apr 12 18:35:23 UTC 2013


On 04/12/2013 04:57 PM, Jakub Hrozek wrote:
> On Thu, Apr 11, 2013 at 11:35:52AM +0200, Michal Židek wrote:
>> New patch attached.
>>
>> Thanks
>> Michal
>>
>> +        if (IS_SUBDOMAIN(dinfo)) {
>> +            name_lower = sss_tc_utf8_str_tolower(tmp_ctx, parsed_name);
>> +            domain_lower = sss_tc_utf8_str_tolower(tmp_ctx, parsed_domain);
>> +            if (!name_lower || !domain_lower) {
>> +                DEBUG(SSSDBG_CRIT_FAILURE, ("Out of memory\n"));
>> +                ret = ENOMEM;
>> +                goto done;
>> +            }
>
> One last nitpick -- while this code is technically correct now, it might not
> be in future, we should also check the case_sensitive flag in dinfo and
> only lowercase based on the value of the flag.

Ok. I have also slightly changed the code flow in update_filter() 
function to make it more readable and added new parameter to force case 
sensibility (for autofs maps). New patch attached.

Thanks
Michal

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-sss_cache-support-for-subdomains.patch
Type: text/x-patch
Size: 14080 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20130412/c2eda45b/attachment.bin>


More information about the sssd-devel mailing list