[PATCH] Add support for removing removing services from the firewall (#957809)

Martin Kolman mkolman at redhat.com
Mon Oct 7 09:43:25 UTC 2013


On Fri, 2013-10-04 at 13:44 -0700, Brian C. Lane wrote:
> On Fri, Oct 04, 2013 at 06:07:05PM +0200, Martin Kolman wrote:
> 
> > @@ -520,6 +521,9 @@ class Firewall(commands.firewall.F14_Firewall):
> >          for port in self.ports:
> >              args += [ "--port=%s" % (port,) ]
> >  
> > +        for remove_service in self.remove_services:
> > +            args += ["--remove-service=%s" % remove_service]
> > +
> 
> I have since changed my mind on the (xxx,) form for single tuples, but
> this should match the surrounding code just for clarity.
OK, fixing locally.
> 
> 
> >          for service in self.services:
> >              args += [ "--service=%s" % (service,) ]
> 
> _______________________________________________
> anaconda-patches mailing list
> anaconda-patches at lists.fedorahosted.org
> https://lists.fedorahosted.org/mailman/listinfo/anaconda-patches




More information about the anaconda-patches mailing list