[PATCH] Add support for removing removing services from the firewall (#957809)

Brian C. Lane bcl at redhat.com
Fri Oct 4 20:44:58 UTC 2013


On Fri, Oct 04, 2013 at 06:07:05PM +0200, Martin Kolman wrote:

> @@ -520,6 +521,9 @@ class Firewall(commands.firewall.F14_Firewall):
>          for port in self.ports:
>              args += [ "--port=%s" % (port,) ]
>  
> +        for remove_service in self.remove_services:
> +            args += ["--remove-service=%s" % remove_service]
> +

I have since changed my mind on the (xxx,) form for single tuples, but
this should match the surrounding code just for clarity.


>          for service in self.services:
>              args += [ "--service=%s" % (service,) ]

-- 
Brian C. Lane | Anaconda Team | IRC: bcl #anaconda | Port Orchard, WA (PST8PDT)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 482 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/anaconda-patches/attachments/20131004/e3ce9f55/attachment.sig>


More information about the anaconda-patches mailing list