Change in vdsm[master]: storage: add support for blkdiscard command

nsoffer at redhat.com nsoffer at redhat.com
Wed May 4 22:42:48 UTC 2016


Nir Soffer has posted comments on this change.

Change subject: storage: add support for blkdiscard command
......................................................................


Patch Set 6:

(2 comments)

https://gerrit.ovirt.org/#/c/35629/6/lib/vdsm/storage/blkdiscard.py
File lib/vdsm/storage/blkdiscard.py:

Line 28: _blkdiscard = utils.CommandPath("blkdiscard",
Line 29:                                 "/sbin/blkdiscard",)
Line 30: 
Line 31: 
Line 32: class BlkDiscardError(Exception):
Not needed, use cmdutils.Error instead.
Line 33:     def __init__(self, ecode, stdout, stderr):
Line 34:         self.ecode = ecode
Line 35:         self.stdout = stdout
Line 36:         self.stderr = stderr


Line 39:         return "ecode={0}, stdout={1}, stderr={2}".format(
Line 40:             self.ecode, self.stdout, self.stderr)
Line 41: 
Line 42: 
Line 43: def run_blkdiscard(device):
Should be named blkdiscard.
Line 44:     cmd = [_blkdiscard.cmd]
Line 45:     cmd.append(device)
Line 46: 
Line 47:     rc, out, err = commands.execCmd(cmd, deathSignal=signal.SIGKILL)


-- 
To view, visit https://gerrit.ovirt.org/35629
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I2ea7dd19fadc600b8fe78fb436ae430d35f52165
Gerrit-PatchSet: 6
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Adam Litke <alitke at redhat.com>
Gerrit-Reviewer: Ala Hino <ahino at redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland at redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenkins CI RO
Gerrit-Reviewer: Nir Soffer <nsoffer at redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan at redhat.com>
Gerrit-Reviewer: Yaniv Kaul <ykaul at redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation at ovirt.org>
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list