Change in vdsm[master]: net: Removing 'link' scoped addresses from the ip address list

mmirecki at redhat.com mmirecki at redhat.com
Wed Mar 2 17:16:42 UTC 2016


Marcin Mirecki has posted comments on this change.

Change subject: net: Removing 'link' scoped addresses from the ip address list
......................................................................


Patch Set 2:

(3 comments)

https://gerrit.ovirt.org/#/c/54211/2/tests/network/netinfo_test.py
File tests/network/netinfo_test.py:

Line 319:             """filter away ipv6 link local addresses that may or may not exist
Line 320:             on the device depending on OS configuration"""
Line 321:             ipv4addr, ipv4netmask, ipv4addrs, ipv6addrs = \
Line 322:                 addresses.getIpInfo(*a, **kw)
Line 323:             ipv6addrs = [
> heh, without the dropped condition, this is a NO-OP.
Done
Line 324:                 addr for addr in ipv6addrs]
Line 325:             return ipv4addr, ipv4netmask, ipv4addrs, ipv6addrs
Line 326: 
Line 327:         IP_ADDR = '192.0.2.2'


Line 320:             on the device depending on OS configuration"""
Line 321:             ipv4addr, ipv4netmask, ipv4addrs, ipv6addrs = \
Line 322:                 addresses.getIpInfo(*a, **kw)
Line 323:             ipv6addrs = [
Line 324:                 addr for addr in ipv6addrs]
> .. unless I'm mistaken, and this code is still needed to filter-out the ipv
Looking deeper into what is happening inside, we only check against:
        linklocal_network = IPv4Network('169.254.0.0/16')
        linklocal_network = IPv6Network('fe80::/10')
So it looks like we can remove this too.
Line 325:             return ipv4addr, ipv4netmask, ipv4addrs, ipv6addrs
Line 326: 
Line 327:         IP_ADDR = '192.0.2.2'
Line 328:         IP_ADDR_SECOND = '192.0.2.3'


Line 368: test_drop_link_addr
> link addr is another name for a mac, better use some other name. 
Done


-- 
To view, visit https://gerrit.ovirt.org/54211
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: If8bbee8deebdfc617bc82f811e8a20e4db11ebb5
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Marcin Mirecki <mmirecki at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Edward Haas <edwardh at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Marcin Mirecki <mmirecki at redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits at redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation at ovirt.org>
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list