Change in vdsm[master]: virt: extract destroyVm helper

mzamazal at redhat.com mzamazal at redhat.com
Fri Feb 26 12:53:48 UTC 2016


Milan Zamazal has posted comments on this change.

Change subject: virt: extract destroyVm helper
......................................................................


Patch Set 1: Code-Review+1

(2 comments)

Conditional +1, see the comments in the code.

https://gerrit.ovirt.org/#/c/53932/1/vdsm/virt/vm.py
File vdsm/virt/vm.py:

Line 3860: retry
Better name than `retry'? See the following comment.


Line 3862:             res = self._destroyVmForceful()
Line 3863:         return res
Line 3864: 
Line 3865:     def _destroyVmGraceful(self):
Line 3866:         retry = False
`retry' is not a good name here: _destroyVmGraceful shouldn't make assumptions about what to do outside it, it should just report its result. So something like `failed', `success' or `error' would be a better name.
Line 3867:         try:
Line 3868:             self._dom.destroyFlags(libvirt.VIR_DOMAIN_DESTROY_GRACEFUL)
Line 3869:         except libvirt.libvirtError as e:
Line 3870:             # after succesfull migraions


-- 
To view, visit https://gerrit.ovirt.org/53932
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id152a7aae3d4f644f34703f7f0b5f98035e4e295
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Polednik <mpolednik at redhat.com>
Gerrit-Reviewer: Milan Zamazal <mzamazal at redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation at ovirt.org>
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list