Change in vdsm[master]: storage: fix spec normalization when mounting

ishaby at redhat.com ishaby at redhat.com
Thu Apr 28 08:31:07 UTC 2016


Idan Shaby has posted comments on this change.

Change subject: storage: fix spec normalization when mounting
......................................................................


Patch Set 11:

(4 comments)

https://gerrit.ovirt.org/#/c/55182/10/tests/fileUtilTests.py
File tests/fileUtilTests.py:

Line 279:             self.assertRaises(OSError, fileUtils.atomic_symlink, target, link)
Line 280: 
Line 281: 
Line 282: @expandPermutations
Line 283: class TestNormalizePath(TestCaseBase):
> The function is called now normalize_path, so the test should be called Tes
Done
Line 284: 
Line 285:     @permutations([
Line 286:         # Local paths
Line 287:         ("/mnt/path", "/mnt/path"),


Line 287:         ("/mnt/path", "/mnt/path"),
Line 288:         ("/mnt/path/", "/mnt/path"),
Line 289:         ("/mnt/path//", "/mnt/path"),
Line 290: 
Line 291:         # Remote paths
> We need to add more permutations for normalizing local paths (these without
Done
Line 292:         ("server:/path", "server:/path"),
Line 293:         ("server:/path/", "server:/path"),
Line 294:         ("server:/path//", "server:/path"),
Line 295:         ("server:/", "server:/"),


https://gerrit.ovirt.org/#/c/55182/10/vdsm/storage/hsm.py
File vdsm/storage/hsm.py:

Line 2762:                 # Filter domains according to 'domainClass'
Line 2763:                 if domainClass and domainClass != dom.getDomainClass():
Line 2764:                     domains.remove(sdUUID)
Line 2765:                     continue
Line 2766:                 # Filter domains according to 'remotePath'
> This code normalize removePath multiple times for each domain, instead of o
Done
Line 2767:                 if remotePath and remotePath != dom.getRemotePath():
Line 2768:                     domains.remove(sdUUID)
Line 2769:                     continue
Line 2770:             except Exception:


https://gerrit.ovirt.org/#/c/55182/10/vdsm/storage/nfsSD.py
File vdsm/storage/nfsSD.py:

Line 67
Line 68
Line 69
Line 70
Line 71
> We should normalize the remotePath here - and use the same name so it is no
Done


-- 
To view, visit https://gerrit.ovirt.org/55182
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I9f244eb903fc049c726efba69f37b3b5fb01b561
Gerrit-PatchSet: 11
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby at redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland at redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Nir Soffer <nsoffer at redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan at redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation at ovirt.org>
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list