Change in vdsm[master]: asyncore: heartbeat fix

ykaplan at redhat.com ykaplan at redhat.com
Sun Mar 22 13:43:11 UTC 2015


Yeela Kaplan has posted comments on this change.

Change subject: asyncore: heartbeat fix
......................................................................


Patch Set 1:

(1 comment)

https://gerrit.ovirt.org/#/c/38988/1/lib/yajsonrpc/betterAsyncore.py
File lib/yajsonrpc/betterAsyncore.py:

Line 202: 
Line 203:         self._map.clear()
Line 204: 
Line 205:     def _get_timeout(self, map):
Line 206:         timeout = 30.0
> Maybe this should configurable or not passed at all if None?
If this is the asyncore timeout, can you maybe import the constant from there, instead of just writing the number?
In case anything changes,
and also more readable...
Line 207:         for disp in self._map.values():
Line 208:             if hasattr(disp, "next_check_interval"):
Line 209:                 interval = disp.next_check_interval()
Line 210:                 if interval is not None and interval >= 0:


-- 
To view, visit https://gerrit.ovirt.org/38988
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Icad61fb62509764e8ecdd6f87ef60557f4465368
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski at gmail.com>
Gerrit-Reviewer: Dima Kuznetsov <dkuznets at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski at gmail.com>
Gerrit-Reviewer: Saggi Mizrahi <smizrahi at redhat.com>
Gerrit-Reviewer: Yaniv Bronhaim <ybronhei at redhat.com>
Gerrit-Reviewer: Yeela Kaplan <ykaplan at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list