Change in vdsm[master]: v2v: get VM information from OVA file

fromani at redhat.com fromani at redhat.com
Thu Aug 13 14:06:17 UTC 2015


Francesco Romani has posted comments on this change.

Change subject: v2v: get VM information from OVA file
......................................................................


Patch Set 10: Code-Review+1

(2 comments)

partial ACK.
Since we're cleaning up schema and return value, fuether comments on the topic.

https://gerrit.ovirt.org/#/c/43271/10/vdsm/rpc/Bridge.py
File vdsm/rpc/Bridge.py:

Line 409:     'Host_getConnectedStoragePools': {'ret': 'poollist'},
Line 410:     'Host_getDeviceList': {'ret': 'devList'},
Line 411:     'Host_getDevicesVisibility': {'ret': 'visible'},
Line 412:     'Host_getExternalVMs': {'ret': 'vmList'},
Line 413:     'Host_getExternalVmFromOva': {'ret': 'vmList'},
...here (see comment in v2v.py)
Line 414:     'Host_getConvertedVm': {'ret': 'ovf'},
Line 415:     'Host_getHardwareInfo': {'ret': 'info'},
Line 416:     'Host_getLVMVolumeGroups': {'ret': 'vglist'},
Line 417:     'Host_getStats': {'ret': 'info'},


https://gerrit.ovirt.org/#/c/43271/10/vdsm/v2v.py
File vdsm/v2v.py:

Line 185:     _add_general_ovf_info(vm, root, ns)
Line 186:     _add_disks_ovf_info(vm, root, ns)
Line 187:     _add_networks_ovf_info(vm, root, ns)
Line 188: 
Line 189:     return response.success(vmList=vm)
ok, but let's make a step further: now this is misleading, is not a list anymore rather a single value. I'd rename it to something like

  info=vm

or

  vmInfo=vm

let's not forget to check and, as likely needed, to update Bridge.py.
Line 190: 
Line 191: 
Line 192: def get_converted_vm(job_id):
Line 193:     try:


-- 
To view, visit https://gerrit.ovirt.org/43271
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I3c55c846f837bb5bf363717e05daabf5ee6631ca
Gerrit-PatchSet: 10
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shavivi at redhat.com>
Gerrit-Reviewer: Adam Litke <alitke at redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Michal Skrivanek <mskrivan at redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list