Change in vdsm[master]: vmdevices: rename makeDeviceDict to makeDevMap

mpolednik at redhat.com mpolednik at redhat.com
Thu Apr 23 09:06:52 UTC 2015


Martin Polednik has uploaded a new change for review.

Change subject: vmdevices: rename makeDeviceDict to makeDevMap
......................................................................

vmdevices: rename makeDeviceDict to makeDevMap

To keep a consistent naming across devices subsystem, this patch
changes name of this method to conform naming defined in
http://www.ovirt.org/Feature/VmDevices_rework#Current_state_of_devices

Change-Id: I28e291f3b4141e3317d3beaa7cb6c01c70835677
Signed-off-by: Martin Polednik <mpolednik at redhat.com>
---
M vdsm/virt/vm.py
1 file changed, 3 insertions(+), 3 deletions(-)


  git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/65/40165/1

diff --git a/vdsm/virt/vm.py b/vdsm/virt/vm.py
index 331cfcd..a214869 100644
--- a/vdsm/virt/vm.py
+++ b/vdsm/virt/vm.py
@@ -656,7 +656,7 @@
                      (hwclass.TPM, vmdevices.core.Tpm),
                      (hwclass.HOSTDEV, vmdevices.hostdevice.HostDevice))
 
-    def _makeDeviceDict(self):
+    def _makeDevMap(self):
         return dict((dev, []) for dev, _ in self.DeviceMapping)
 
     def _makeChannelPath(self, deviceName):
@@ -728,7 +728,7 @@
         self.stopDisksStatsCollection()
         self._vmCreationEvent = threading.Event()
         self._pathsPreparedEvent = threading.Event()
-        self._devices = self._makeDeviceDict()
+        self._devices = self._makeDevMap()
 
         self._connection = libvirtconnection.get(cif)
         if 'vmName' not in self.conf:
@@ -844,7 +844,7 @@
         Return the "devices" section of this Vm's conf.
         If missing, create it according to old API.
         """
-        devices = self._makeDeviceDict()
+        devices = self._makeDevMap()
 
         # For BC we need to save previous behaviour for old type parameters.
         # The new/old type parameter will be distinguished


-- 
To view, visit https://gerrit.ovirt.org/40165
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I28e291f3b4141e3317d3beaa7cb6c01c70835677
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Martin Polednik <mpolednik at redhat.com>


More information about the vdsm-patches mailing list