Change in vdsm[master]: vdsm: add functionality to detach host devices

danken at redhat.com danken at redhat.com
Fri Oct 31 12:06:27 UTC 2014


Dan Kenigsberg has posted comments on this change.

Change subject: vdsm: add functionality to detach host devices
......................................................................


Patch Set 4: Code-Review-1

(1 comment)

nit about naming.

http://gerrit.ovirt.org/#/c/32389/4/vdsm/hostdev.py
File vdsm/hostdev.py:

Line 114: 
Line 115:     return devices
Line 116: 
Line 117: 
Line 118: def parse_and_detach_if_detachable(device_name):
detach_if_detachable() is complex-enough name.

instead of the "parse_and_" prefix, place a docspace explaining the dictionary that is returned.
Line 119:     libvirt_device, device_params = _get_device_ref_and_params(device_name)
Line 120: 
Line 121:     if device_params['capability'] in _DETACH_REQUIRING_CAPS:
Line 122:         libvirt_device.detachFlags(None)


-- 
To view, visit http://gerrit.ovirt.org/32389
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I530fed56831314286942b8afa62900208812bfb5
Gerrit-PatchSet: 4
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Martin Polednik <mpolednik at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Martin Polednik <mpolednik at redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek at redhat.com>
Gerrit-Reviewer: Michal Skrivanek <mskrivan at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list