Change in vdsm[master]: factor out parts of setupNetworks for better readability

asegurap at redhat.com asegurap at redhat.com
Thu Nov 27 13:20:54 UTC 2014


Antoni Segura Puimedon has posted comments on this change.

Change subject: factor out parts of setupNetworks for better readability
......................................................................


Patch Set 1: Code-Review-1

(1 comment)

http://gerrit.ovirt.org/#/c/35659/1/vdsm/network/api.py
File vdsm/network/api.py:

Line 602: 
Line 603: def _add_missing_networks(configurator, networks_to_add, bondings, force,
Line 604:                           logger):
Line 605:     # We need to use the newest host info
Line 606:     _netinfo = netinfo.NetInfo()
You should put _netinfo as a optional param defaulting to None and then:

if _netinfo is None:
    _netinfo = netinfo.NetInfo()
else:
    _netinfo.updateDevices()
Line 607:     _netinfo.updateDevices()
Line 608:     for network, network_attrs in networks_to_add.iteritems():
Line 609:         d = dict(network_attrs)
Line 610:         if 'bonding' in d:


-- 
To view, visit http://gerrit.ovirt.org/35659
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0c3355aab2804ffaaf8b611de224ef3d2e616eef
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Ido Barkan <ibarkan at redhat.com>
Gerrit-Reviewer: Antoni Segura Puimedon <asegurap at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list