Change in vdsm[master]: sampling: rename variables to make code nicer

danken at redhat.com danken at redhat.com
Fri Nov 21 16:12:03 UTC 2014


Dan Kenigsberg has posted comments on this change.

Change subject: sampling: rename variables to make code nicer
......................................................................


Patch Set 5: Code-Review-1

(1 comment)

http://gerrit.ovirt.org/#/c/34390/5/vdsm/virt/sampling.py
File vdsm/virt/sampling.py:

Line 333:         """
Line 334:         if len(self._samples) < 2:
Line 335:             return None, None, None
Line 336: 
Line 337:         first_timestamp, first_value = self._samples[0]
I actually likes the term "sample" (the singular of _samples) better than a vague "value".
Line 338:         last_timestamp, last_value = self._samples[-1]
Line 339: 
Line 340:         elapsed_time = last_timestamp - first_timestamp
Line 341:         return first_value, last_value, elapsed_time


-- 
To view, visit http://gerrit.ovirt.org/34390
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I14caeb163552a659d1e7fcc103ac7fc9f1697bad
Gerrit-PatchSet: 5
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list