Change in vdsm[master]: vdsm: verifyingTransport testing

nsoffer at redhat.com nsoffer at redhat.com
Fri Jun 27 18:38:12 UTC 2014


Nir Soffer has posted comments on this change.

Change subject: vdsm: verifyingTransport testing
......................................................................


Patch Set 7:

(2 comments)

http://gerrit.ovirt.org/#/c/28858/7/tests/sslTests.py
File tests/sslTests.py:

Line 28: import tempfile
Line 29: import threading
Line 30: import xmlrpclib
Line 31: 
Line 32: from sslHelper import KEY_FILE, CRT_FILE, OTHER_KEY_FILE, OTHER_CRT_FILE
can you rename this to sslhelper ? modules names should not use mixedCase. We have such modules (and Python standard library also) but pep8 recommend lowercase module names.
Line 33: from testrunner import VdsmTestCase as TestCaseBase
Line 34: from vdsm.sslutils import SSLServerSocket
Line 35: from vdsm.sslutils import VerifyingSafeTransport
Line 36: 


Line 64:     def serve_forever(self):
Line 65:         try:
Line 66:             self.server.serve_forever()
Line 67:         except:
Line 68:             # we want to hide server side exception
> could you catch only the expected exceptions here? and if you keep the comm
Please replace the comment with with the text in your reply in version 6:
http://gerrit.ovirt.org/#/c/28858/6/tests/sslTests.py

The current comment does not add any new information. I can tell by looking at the code that you want to hide server side exception. What I cannot tell is why.
Line 69:             pass
Line 70: 
Line 71:     def stop(self):
Line 72:         self.server.shutdown()


-- 
To view, visit http://gerrit.ovirt.org/28858
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I1a706d4d90fdf446b06530288d947d96934e45f2
Gerrit-PatchSet: 7
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski at gmail.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Nir Soffer <nsoffer at redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski at gmail.com>
Gerrit-Reviewer: Saggi Mizrahi <smizrahi at redhat.com>
Gerrit-Reviewer: Yaniv Bronhaim <ybronhei at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list