Change in vdsm[master]: hostdev: report totalvfs

fromani at redhat.com fromani at redhat.com
Mon Dec 8 14:45:08 UTC 2014


Francesco Romani has posted comments on this change.

Change subject: hostdev: report totalvfs
......................................................................


Patch Set 3: Code-Review-1

(2 comments)

A question and a minor comment about tests improvement.
-1 for visibility and for the question, but patch looks quite good to me.

http://gerrit.ovirt.org/#/c/35891/3/tests/hostdevTests.py
File tests/hostdevTests.py:

Line 373:     def listAllDevices(self, flags=0):
Line 374:         return self._virNodeDevices
Line 375: 
Line 376: 
Line 377: def _avoidSysfsLookup(x):
I'd rename to something reminding us that it is a fake.
Also, can we have a better name than just "x"? :)
Probably device_id (device_name? dev_name?) is already good enough.
Line 378:     if x == 'pci_0000_00_19_0':
Line 379:         return '7'
Line 380: 
Line 381:     raise IOError


http://gerrit.ovirt.org/#/c/35891/3/vdsm/hostdev.py
File vdsm/hostdev.py:

Line 65: 
Line 66:     try:
Line 67:         params['totalvfs'] = _sriov_totalvfs(name)
Line 68:     except IOError:
Line 69:         # Device does not support sriov, we can safely go on
I assume that the device format (see _name_to_pci_path) is part of the kernel/userspace ABI and thus will not change,
is that correct?
Line 70:         pass
Line 71: 
Line 72:     return params
Line 73: 


-- 
To view, visit http://gerrit.ovirt.org/35891
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ic54228deb64db200615ef8e2ba8f51e449e68022
Gerrit-PatchSet: 3
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Martin Polednik <mpolednik at redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani at redhat.com>
Gerrit-Reviewer: Martin Betak <mbetak at redhat.com>
Gerrit-Reviewer: Martin Polednik <mpolednik at redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list