Change in vdsm[master]: vm: fix _devices access in _highWrite

fsimonce at redhat.com fsimonce at redhat.com
Thu Nov 7 11:42:09 UTC 2013


Federico Simoncelli has posted comments on this change.

Change subject: vm: fix _devices access in _highWrite
......................................................................


Patch Set 3:

(2 comments)

....................................................
File vdsm/vm.py
Line 2280:         self.log.debug('new rtc offset %s', timeOffset)
Line 2281:         with self._confLock:
Line 2282:             self.conf['timeOffset'] = timeOffset
Line 2283: 
Line 2284:     def checkDrivesForExtension(self):
Actually it's not extending, It's checking if one or more extensions are in order. Calling this method is not always resulting in an extension. I'll happily accept any better name that is conveying that idea.
Line 2285:         extend = []
Line 2286: 
Line 2287:         for drive in self._devices[DISK_DEVICES]:
Line 2288:             if not drive.blockDev or drive.format != 'cow':


Line 2299:                     "capacity %s for volume %s on domain %s", alloc,
Line 2300:                     capacity, drive.domainID, drive.volumeID)
Line 2301:                 self.pause(pauseCode='EOTHER')
Line 2302: 
Line 2303:         for drive, capacity, alloc, physical in extend:
I'm not entirely sure about this one, I understand you want to skip the extension (and pause) for the faulty one, but I don't see any relevant reason to prevent also the other ones. Anyway we'll address this in another patch. I'm going to transform this into just a plain refactor.
Line 2304:             self.log.info('%s/%s apparent: %s capacity: %s, alloc: %s, '
Line 2305:                           'physical: %s', drive.domainID, drive.volumeID,
Line 2306:                           drive.apparentsize, capacity, alloc, physical)
Line 2307:             self.extendDriveVolume(drive)


-- 
To view, visit http://gerrit.ovirt.org/20966
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I4fd790986b81402847b06810529841cfd7bae119
Gerrit-PatchSet: 3
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Sergey Gotliv <sgotliv at redhat.com>
Gerrit-HasComments: Yes


More information about the vdsm-patches mailing list