Change in vdsm[master]: WIP: Multiple Gateways Feature

asegurap at redhat.com asegurap at redhat.com
Tue Jun 4 14:53:28 UTC 2013


Antoni Segura Puimedon has posted comments on this change.

Change subject: WIP: Multiple Gateways Feature
......................................................................


Patch Set 6: I would prefer that you didn't submit this

(3 inline comments)

A couple of changes originating from the previous patch.

....................................................
File vdsm/multipleGateways.py
Line 20: import os
Line 21: import sys
Line 22: import netaddr
Line 23: from vdsm import netinfo
Line 24: from netconf import iproute2
iproute2 wrapper (not the configurator) will have to be moved, so this line will change.
Line 25: 
Line 26: 
Line 27: class MultipleGatewaysConfigurator(object):
Line 28:     def __init__(self, isStatic, device):


Line 23: from vdsm import netinfo
Line 24: from netconf import iproute2
Line 25: 
Line 26: 
Line 27: class MultipleGatewaysConfigurator(object):
The same I commented on the wrapper about ipaddr and gateway probably applies here.
Line 28:     def __init__(self, isStatic, device):
Line 29:         self.isStatic = isStatic
Line 30:         self.device = device
Line 31:         self.ipaddr = None


Line 52:         filePath = os.path.join(netinfo.NET_CONF_DIR,
Line 53:                                 '%s-%s' % (type, self.device))
Line 54:         with open(filePath, 'w') as file:
Line 55:             for command in commands:
Line 56:                 file.write(str(command) + '\n')
I'd appreciate a different name than 'file'. It overrides the name of the 'file' builtin, which makes my subconscious want to say file -> open, but then I realize it's just a var.
Line 57: 
Line 58:     def _addRoutesStatic(self, routes):
Line 59:         self._writeCommands(routes, type='route')
Line 60: 


--
To view, visit http://gerrit.ovirt.org/15207
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0224d896724b9cdc44215e92f0da0be71fd19038
Gerrit-PatchSet: 6
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Assaf Muller <amuller at redhat.com>
Gerrit-Reviewer: Antoni Segura Puimedon <asegurap at redhat.com>
Gerrit-Reviewer: Assaf Muller <amuller at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Livnat Peer <lpeer at redhat.com>
Gerrit-Reviewer: Mark Wu <wudxw at linux.vnet.ibm.com>
Gerrit-Reviewer: oVirt Jenkins CI Server


More information about the vdsm-patches mailing list