Change in vdsm[master]: Use domain proxies instead of actual domain references

ewoud at kohlvanwijngaarden.nl ewoud at kohlvanwijngaarden.nl
Mon May 28 19:10:05 UTC 2012


Ewoud Kohl van Wijngaarden has posted comments on this change.

Change subject: Use domain proxies instead of actual domain references
......................................................................


Patch Set 25: (3 inline comments)

....................................................
File vdsm/storage/sdc.py
Line 39: class DomainProxy(object):
How about StorageDomainProxy?

Line 51:         return self._cache._realProduce(self._sdUUID)
I think getRealDomain should be "private" since you already proxy all attributes. Naming it _getRealDomain makes it clear it's not meant to be called unless you know what you're doing.

Line 114:     def _realProduce(self, sdUUID):
I think Dan mentioned it before, but I agree that mixing these two makes it harder to understand the flow. How about a separate StorageDomainProxyCache which only hold DomainProxies?

--
To view, visit http://gerrit.ovirt.org/3044
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ifdedd601ca25e6cac3f1f68f2917776401c0d838
Gerrit-PatchSet: 25
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Saggi Mizrahi <smizrahi at redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Eduardo <ewarszaw at redhat.com>
Gerrit-Reviewer: Ewoud Kohl van Wijngaarden <ewoud at kohlvanwijngaarden.nl>
Gerrit-Reviewer: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Saggi Mizrahi <smizrahi at redhat.com>


More information about the vdsm-patches mailing list