Change in vdsm[master]: BZ#688640 - Remove subChainSizeCalc() and getSubChain(). Rem...

abaron at redhat.com abaron at redhat.com
Tue May 1 08:59:14 UTC 2012


Ayal Baron has posted comments on this change.

Change subject: BZ#688640 - Remove subChainSizeCalc() and getSubChain(). Remove getAllChildrenList().
......................................................................


Patch Set 8: I would prefer that you didn't submit this

(12 inline comments)

....................................................
Commit Message
Line 8: Remove getAllChildrenList().
why?

....................................................
File vdsm/storage/image.py
Line 959:         srcVol = chain[-1]
s/srcVol/dstVol/

Line 1006:         rChain = [vol.volUUID for vol in chain if srcVol.volUUID != srcVolParams['volUUID']]
s/rChain/rmChain/

Line 1011:     # TODO: Review this and accessory functions
???

Line 1023:         # Filter volumes related to this image (without the eventual template)
comment is wrong and redundant

Line 1024:         volsImgs = dict((k, v) for k, v in allVols.iteritems()
as in previous patch, should be a function and variable name is wrong

Line 1033:         srcVol = vols[successor]
s/successor/something legible/
s/srcVol/dstVol/ ????????????????????

Line 1034:         srcVolParams = srcVol.getVolumeParams()
s/srcVolParams/dstVolParams/

Line 1036:         for vUUID, vol in vols.iteritems():
why vUUID here and vName elsewhere?

Line 1048:         volUUID = successor
s/volUUID/curVol/ ?

Line 1053:         else:
get rid of else
you can change while to:
endVol = vols[ancestor].getParent()
while (curVol != endVol):

Line 1057:         sz = volParams['size']
sz is usually string zero so not that good a name. why not 'imageApparentSize' ?
s/chainSize/chainRealSize/

requiredSpace = min(chainRealSize, imageApparentSize) * 1.1

--
To view, visit http://gerrit.ovirt.org/3468
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Iffbbf71269eddb53c032c381d10e20b771c47c6b
Gerrit-PatchSet: 8
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Eduardo <ewarszaw at redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron at redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken at redhat.com>
Gerrit-Reviewer: Eduardo <ewarszaw at redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce at redhat.com>
Gerrit-Reviewer: Igor Lvovsky <ilvovsky at redhat.com>


More information about the vdsm-patches mailing list