Change in vdsm[master]: Hotplug/Hotunplug disks

ewarszaw at redhat.com ewarszaw at redhat.com
Sun Dec 4 15:19:01 UTC 2011


Eduardo has posted comments on this change.

Change subject: Hotplug/Hotunplug disks
......................................................................


Patch Set 2: I would prefer that you didn't submit this

(7 inline comments)

....................................................
File vdsm/clientIF.py
Line 611:         self.vmContainerLock.acquire()
Can use with?

Line 613:             for param in ('vmId', 'drives'):
Please split to function the param verification and reuse below.

....................................................
File vdsm/libvirtvm.py
Line 1078:     def _validateDiskParams(self, diskParams):
Unify with the previous validation.
validateMinimalKeySet(dict, keys)

Line 1112:             self._getUnderlyingDriveInfo()
Please rename it.

Line 1141:             # Find proper drive in _preparedDrives dictionary and torn it down.
turn

....................................................
File vdsm/vm.py
Line 404:                 return d
self._drives = [d for d in self._drives if d.path != drive.path]

Line 409:             drive['index'] = idx
Do it outside.

--
To view, visit http://gerrit.ovirt.org/409
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I5feefdba390c4b885aaa5e61f40410419acb3b3c
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Igor Lvovsky <ilvovsky at redhat.com>
Gerrit-Reviewer: Eduardo <ewarszaw at redhat.com>


More information about the vdsm-patches mailing list