[SSSD-users] 1.11.5 ddns failure on Ubuntu 14.04 [SOLVED]]

Longina Przybyszewska longina at sdu.dk
Thu Jun 19 10:27:48 UTC 2014


I hit the same problem "ddns failure" with desktop client Ubuntu 14.04.

Following discussion, my setup seems to be correct, but host record disappeared from DNS and can't be updated.
After joining with 'realm' DNS A record was correct set up.  
I work on laptop which I use to suspend overnight.

Debug output:

root at skywalker:/home-local/longinap# cat /etc/hostnames
skywalker

root at skywalker:/home-local/longinap# cat /etc/hosts
127.0.0.1	localhost
127.0.1.1	skywalker.domain.org skywalker
10.144.4.254	zeta.domain.org zeta
----------------------------
root at skywalker:/home-local/longinap# hostname -s
skywalker

root at skywalker:/home-local/longinap# hostname -f
skywalker.domain.org

root at skywalker:/home-local/longinap# dnsdomainname
domain.org

root at skywalker:/home-local/longinap# cat /etc/nsswitch.conf
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat sss
group:          compat sss
shadow:         compat

#hosts:          files mdns4_minimal [NOTFOUND=return] dns
hosts:		 files dns myhostname
networks:       files
protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis sss
sudoers:        files sss
---------------------------------
longinap at skywalker:~$ host skywalker.domain.org
Host skywalker.domain.org not found: 3(NXDOMAIN)

---------------/var/log/sssd...----------------------
 [sssd[be[domain.org]]] [sdap_dyndns_update_done] (0x0080): nsupdate failed, retrying with server name
 [sssd[be[domain.org]]] [nsupdate_msg_create_common] (0x0200): Creating update message for server [nat-vdc0a.domain.org] and realm [DOMAIN.ORG]
. [sssd[be[domain.org]]] [be_nsupdate_create_fwd_msg] (0x0400):  -- Begin nsupdate message -- 
server nat-vdc0a.domain.org
realm DOMAIN.ORG
update delete skywalker. in A
send
update delete skywalker. in AAAA
send
update add skywalker. 3600 in A 10.80.8.91
send
 [sssd[be[domain.org]]] [be_nsupdate_create_fwd_msg] (0x0400):  -- End nsupdate message -- 
 [sssd[be[domain.org]]] [child_handler_setup] (0x2000): Setting up signal handler up for pid [5338]
 [sssd[be[domain.org]]] [child_handler_setup] (0x2000): Signal handler set up for pid [5338]
 [sssd[be[domain.org]]] [write_pipe_handler] (0x0400): All data has been sent!
 [sssd[be[domain.org]]] [be_nsupdate_args] (0x0200):  [sssd[be[domain.org]]] [nsupdate_child_stdin_done] (0x1000): nsupdate auth type: GSS-TSIG
Sending nsupdate data complete

 [sssd[be[domain.org]]] [sbus_dispatch] (0x4000): dbus conn: 0x1cbdca0
 [sssd[be[domain.org]]] [sbus_dispatch] (0x4000): Dispatching.
 [sssd[be[domain.org]]] [sbus_message_handler] (0x4000): Received SBUS method [ping]
 [sssd[be[domain.org]]] [nsupdate_child_timeout] (0x0020): Timeout reached for dynamic DNS update
 [sssd[be[domain.org]]] [be_nsupdate_done] (0x0040): nsupdate child execution failed [1432158229]: Dynamic DNS update timed out
 [sssd[be[domain.org]]] [sdap_id_op_destroy] (0x4000): releasing operation connection
 [sssd[be[domain.org]]] [ad_dyndns_sdap_update_done] (0x0040): Dynamic DNS update failed [1432158229]: Dynamic DNS update timed out
 [sssd[be[domain.org]]] [ad_dyndns_nsupdate_done] (0x0040): Updating DNS entry failed [1432158229]: Dynamic DNS update timed out
 [sssd[be[domain.org]]] [child_sig_handler] (0x1000): Waiting for child [5338].
 [sssd[be[domain.org]]] [child_sig_handler] (0x0020): child [5338] was terminated by signal [9].

Best,
Longina


-----Original Message-----
From: sssd-users-bounces at lists.fedorahosted.org [mailto:sssd-users-bounces at lists.fedorahosted.org] On Behalf Of Stephen Gallagher
Sent: 22. maj 2014 15:44
To: sssd-users at lists.fedorahosted.org
Subject: Re: [SSSD-users] 1.11.5 ddns failure on Ubuntu 14.04 [SOLVED]

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/22/2014 09:28 AM, Rowland Penny wrote:
> On 22/05/14 14:06, Stephen Gallagher wrote: On 05/22/2014 08:55 AM, 
> Rowland Penny wrote:
>>>> On 22/05/14 13:50, John Hodrien wrote:
>>>>> On Thu, 22 May 2014, Rowland Penny wrote:
>>>>> 
>>>>>> Not on Ubuntu it isn't ;-)
>>>>> I'd argue that Ubuntu just has incorrect behaviour then.
>>>>> 
>>>>> If you look at man hosts on an ubuntu machine (13.10), you'll see 
>>>>> how they describe it, and the example they provide.  The format 
>>>>> described is:
>>>>> 
>>>>> IP_address canonical_hostname [aliases...]
>>>>> 
>>>>> The example is:
>>>>> 
>>>>> 127.0.0.1     localhost 192.168.1.10  foo.mydomain.org
>>>>> foo 192.168.1.13  bar.mydomain.org    bar
>>>>> 
>>>>> That's the correct format, whether or not Ubuntu applies it.
>>>> Thats all very well for a machine with a fixed ip but what about 
>>>> DHCP ?
>>>> 
> Well, once they adopt systemd, they'll get to start using hosts:
> files dns myhostname
> 
>> OK, 'files dns' I understand but 'myhostname' ? I think that means 
>> that DHCP will store the machines identity in a file somewhere, is 
>> this correct and if so where ?


myhostname is a name-service module that just asks systemd to tell it what IP addresses the system has and what the system's hostname is supposed to be. Then it "magically" returns all the correct and up-to-the-minute information.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlN9/zAACgkQeiVVYja6o6P8hQCggdW2ZtWNYzS9ARsVdXhpDyvH
7+4AoIHnHW4BCv4mm+VwDZxHZuBJkrrK
=VGKa
-----END PGP SIGNATURE-----
_______________________________________________
sssd-users mailing list
sssd-users at lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-users


More information about the sssd-users mailing list