[SSSD] [PATCH] Reduce the code duplication in Data Provider

Jakub Hrozek jhrozek at redhat.com
Mon Nov 16 08:50:09 UTC 2015


On Mon, Nov 16, 2015 at 08:12:06AM +0100, Petr Cech wrote:
> >+struct be_sbus_reply_data {
> >+    dbus_uint16_t err_maj;
> >+    dbus_uint32_t err_min;
> >+    const char *err_msg;
> >+};
> >+
> >+#define BE_SBUS_REPLY_DATA_INIT { .err_maj = DP_ERR_FATAL, \
>                                    --^--
> What does this dot means? It is first time that I see it. Could you explain
> it to me, please? Is it some kind of syntactic sugar?
> 
> Regards
> 
> Petr

It's C99 designated initializers:
    https://gcc.gnu.org/onlinedocs/gcc/Designated-Inits.html

Thank you for reviewing the patch, but it's OK to wait until we fix the
CI environment.


More information about the sssd-devel mailing list