[SSSD] [PATCH] LDAP: group_split_members returns incorrectly ENOMEM

Jakub Hrozek jhrozek at redhat.com
Fri Jun 27 09:09:42 UTC 2014


On Fri, Jun 27, 2014 at 10:52:42AM +0200, Lukas Slebodnik wrote:
> On (27/06/14 10:41), Jakub Hrozek wrote:
> >On Thu, Jun 26, 2014 at 07:37:33PM +0200, Pavel Reichl wrote:
> >> Hello,
> >> 
> >> please see attached patch.
> >> 
> >> Thanks,
> >> PR
> >
> >Would it be more readable if the condition said "num_missing > 0" ?
> or do not call talloc_realloc if num_missing == 0

and call talloc_free() instead, right. Something like:

    if (num_missing == 0) {
        talloc_zfree(missing);
    } else {
        /* realloc */
    }

> 
> talloc_realloc is used here for shrinking array allocated before for cycle
> with talloc_zero_array.



More information about the sssd-devel mailing list