[SSSD] [PATCH 0/5] RFC: Fix various tevent_req style and naming issues

Simo Sorce simo at redhat.com
Tue Oct 23 13:29:28 UTC 2012


While I was working on an unrelated patchset I couldn't help fixing some
of the code to properly use tevent_req style and naming conventions.

This was needed for me to be able to properly read the code, and it will
make it easier to do so in the future.

The krb5_auth.c changes are quite radical because that file was relaly
completely backwards, I have been careful to make sure I did not change
the actual program flow but I haven't tested it yet.

Please check the changes and let me know if you see anything egregiously
wrong. If you like it and have a chance to test the patchset before I get
to it, that is also welcome.

Simo.

Simo Sorce (5):
  Fix tevent_req style for krb5_auth
  Fix ipa_subdomain_id names and tevent_req style
  Fix tevent_req style for get_netgroup in ipa_id
  Streamline ipa_account_info handler
  Use an entry type mask macro to filter entry types

 src/providers/data_provider.h         |   1 +
 src/providers/ipa/ipa_id.c            | 252 +++++++--------
 src/providers/ipa/ipa_id.h            |  10 +-
 src/providers/ipa/ipa_subdomains_id.c |  75 ++---
 src/providers/krb5/krb5_access.c      |   6 +-
 src/providers/krb5/krb5_auth.c        | 556 ++++++++++++++++------------------
 src/providers/krb5/krb5_auth.h        |   2 +-
 src/providers/krb5/krb5_wait_queue.c  |  12 +-
 src/providers/ldap/ldap_id.c          |   2 +-
 src/providers/proxy/proxy_id.c        |   2 +-
 10 files changed, 432 insertions(+), 486 deletions(-)

-- 
1.7.11.4




More information about the sssd-devel mailing list