[SSSD] [PATCH 0/5] Rev 3: Fix various tevent_req style and naming issues

Simo Sorce simo at redhat.com
Wed Nov 28 04:24:53 UTC 2012


This revision should address all concerns raised by Pavel for code that I
actually changed from the original. For patch 1 a calrification I can't
make was asked. I 'fixed' the code as I realized I copied a debug statement
wrapped in an if statement that wasn't in the original code I move around,
so I simply dropped it (the statement is still present but later on in another
part of the code, where it remains from the original code).

For patch for I completely changed approach and simplified the code even more by
removing the switch statement completely, Thanks Pavel, that code looks even
better to me now :)

Simo Sorce (5):
  Fix tevent_req style for krb5_auth
  Fix ipa_subdomain_id names and tevent_req style
  Fix tevent_req style for get_netgroup in ipa_id
  Streamline ipa_account_info handler
  Use an entry type mask macro to filter entry types

 src/providers/data_provider.h         |    1 +
 src/providers/ipa/ipa_id.c            |  294 +++++++--------
 src/providers/ipa/ipa_id.h            |   10 +-
 src/providers/ipa/ipa_subdomains_id.c |   75 ++---
 src/providers/krb5/krb5_access.c      |    6 +-
 src/providers/krb5/krb5_auth.c        |  683 ++++++++++++++++-----------------
 src/providers/krb5/krb5_auth.h        |    6 +-
 src/providers/krb5/krb5_wait_queue.c  |   12 +-
 src/providers/ldap/ldap_id.c          |    2 +-
 src/providers/proxy/proxy_id.c        |    2 +-
 10 files changed, 505 insertions(+), 586 deletions(-)




More information about the sssd-devel mailing list