[SSSD] [PATCH 0/5] Rev 2: Fix various tevent_req style and naming issues

Simo Sorce simo at redhat.com
Wed Nov 7 20:59:03 UTC 2012


While I was working on an unrelated patchset I couldn't help fixing some
of the code to properly use tevent_req style and naming conventions.

This will bring this code in line with our tevent_req coding style and
hopefully make it more readable to eyes used to the tevent_req style.
It also fixes use of some inconsistent function names.

The krb5_auth.c changes are a bit tricky because I needed to change the
flow in several places and built helper functions to reduce a bit some
of the long functions.

I have been careful to make sure I did not change the actual program flow
and the patches work fine for me, so I am now dropping the RFC and asking
for review and inclusion in master.

Also this new patchset integrates the feedback received so far except for the
request of changing debug levels. Although it is normally better to do that,
this patchset is complex enough that I think it is better to avoid the
additional review necessary to also velidate debug messages when refactoring
big functions.

Simo Sorce (5):
  Fix tevent_req style for krb5_auth
  Fix ipa_subdomain_id names and tevent_req style
  Fix tevent_req style for get_netgroup in ipa_id
  Streamline ipa_account_info handler
  Use an entry type mask macro to filter entry types

 src/providers/data_provider.h         |    1 +
 src/providers/ipa/ipa_id.c            |  252 ++++++------
 src/providers/ipa/ipa_id.h            |   10 +-
 src/providers/ipa/ipa_subdomains_id.c |   75 ++---
 src/providers/krb5/krb5_access.c      |    6 +-
 src/providers/krb5/krb5_auth.c        |  685 ++++++++++++++++-----------------
 src/providers/krb5/krb5_auth.h        |    6 +-
 src/providers/krb5/krb5_wait_queue.c  |   12 +-
 src/providers/ldap/ldap_id.c          |    2 +-
 src/providers/proxy/proxy_id.c        |    2 +-
 10 files changed, 501 insertions(+), 550 deletions(-)




More information about the sssd-devel mailing list