[SSSD] [PATCH] Make parse_args skip extra spaces

Stephen Gallagher sgallagh at redhat.com
Thu May 26 16:56:14 UTC 2011


On Thu, 2011-05-26 at 18:15 +0200, Jakub Hrozek wrote:
> https://fedorahosted.org/sssd/ticket/871
> 
> The second patch adds a couple of unit tests to exercise both the old
> behaviour and the multiple spaces.


Patch 0001: Nack.

"if (w) w = 0;" is redundant. "w = 0;" is sufficient here.

Also, while it's unlikely to matter, this code only handles the single
whitespace code. It would be wiser if we used isspace() instead.

For readability purposes, please convert "i", "e" and "w" to the "bool"
type and use true/false.

Finally, please comment this code. It's really difficult to read.


Patch 0002: Please add test cases for tabs.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20110526/2baecf6b/attachment.sig>


More information about the sssd-devel mailing list