[SSSD] [PATCHES] Fail over helper functions and reference counting wrappers

Martin Nagy mnagy at redhat.com
Fri Nov 6 16:50:33 UTC 2009


On Thu, 2009-11-05 at 15:53 -0500, Simo Sorce wrote:
> On Wed, 2009-11-04 at 18:32 +0100, Martin Nagy wrote:
> > On Mon, 2009-11-02 at 16:02 -0500, Simo Sorce wrote:
> > > On Fri, 2009-10-30 at 14:07 +0100, Martin Nagy wrote:
> > > > Hi,
> > > > attached are patches needed for the fail over functionality. The
> > > > service discovery is not there yet, I want to hold of with that until
> > > > I
> > > > have at least a basic SRV-based one so I can test it properly. It's
> > > > possible that we will discover something missing when we'll be
> > > > integrating it into providers. Together with Steven we at least
> > > > figured
> > > > out that for ldapi:// for example we need an "extra" treatment. So I
> > > > made the name resolution optional and you can provide a server with
> > > > user data. The commit messages and header files should explain it
> > > > better.
> > > 
> > > Just a formal NACK.
> > > We discussed changes on IRC.
> > > 
> > > Simo.
> > 
> > New patches attached.
> > 
> > Changes:
> > * use a fail over context instead of a global variable
> > * rename fo_get_server_* to fo_resolve_service_*
> > * rename fo_set_service_status() and enum service_status to use
> > "port_status"
> > * don't use a default port for services
> > * always use only one request for resolving and add even the first
> > request as a subrequest into the queue
> > * put user_data in fo_add_server()
> > * use NULL as a server name to indicate we don't want to do resolving
> > instead of having a boolean for it
> > * in fo_resolve_service_send() only return NULL if the
> > tevent_req_create() fails
> > * add a destructor for lookup hooks, use a different memory context
> > * detect if existing server name, port and user_data combination already
> > exists and return EEXIST if they do
> > 
> > Hope I didn't miss anything.
> 
> Sorry still a NACK, this is the discussion on IRC:
[snip]
> Simo.

OK, should be good now. I also optimized a bit functions for getting
server/port status so they don't always call gettimeofday() if they
don't have to and I also made the code a bit cleaner. New patches
rebased on the current master are attached.

Martin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Add-DLIST_FOR_EACH-macro.patch
Type: text/x-patch
Size: 616 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20091106/d88d2d15/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0002-Add-simple-reference-counting-wrappers-for-talloc.patch
Type: text/x-patch
Size: 12339 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20091106/d88d2d15/attachment-0001.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0003-Add-fail-over-utility-functions.patch
Type: text/x-patch
Size: 29713 bytes
Desc: not available
URL: <https://lists.fedorahosted.org/pipermail/sssd-devel/attachments/20091106/d88d2d15/attachment-0002.bin>


More information about the sssd-devel mailing list