OpenSCAP Error: Conversion of the string "-" to an integer (64 bits) failed: Invalid argument [oval_cmp.c:113]

Jackson, George C III CTR DISA PEO-MA (US) george.c.jackson1.ctr at
Tue May 27 21:32:04 UTC 2014

Hi Shawn,

Sure, I used the URL:

Unfortunately, I cannot use git directly from the RHEL6 host I need this on to as we're a classified site and strict firewall/proxy rules 
won't allow me to. I can only use a browser on one unclassified Windows 
workstation (git not allowed) then transfer my downloads over manually :(

Any other options for me to get the latest?

George Jackson
Cluster Technical Lead
Centaur Operations
Northrop Grumman IS

-----Original Message-----
From: scap-security-guide-bounces at 
[mailto:scap-security-guide-bounces at] On Behalf Of Shawn 
Sent: Tuesday, May 27, 2014 4:02 PM
To: scap-security-guide at
Subject: Re: OpenSCAP Error: Conversion of the string "-" to an integer (64 
bits) failed: Invalid argument [oval_cmp.c:113]

On 5/27/14, 4:54 PM, Jackson, George C III CTR DISA PEO-MA (US) wrote:
> Simon,
> Actually it still doesn't work with the latest
> scap-security-guide-0.5.0-InitialDraft.tar.gz I downloaded directly
> from the git repo this morning. If I use the oscap from Red Hat's
> openscap-1.0.8-1.el6_5.x86_64 with the cmd line of:
> oscap xccdf eval --profile stig-rhel6-server-upstream --results
> hera101-results.xml --report hera101-report.html --cpe
> /usr/share/xml/scap/ssg/content/ssg-rhel6-cpe-dictionary.xml
> /usr/share/xml/scap/ssg/content/ssg-rhel6-xccdf.xml
> I still get:
> Profile "stig-rhel6-server-upstream" was not found.
> If I do the same with --profile stig-server or --profile server I get
> output on a few checks but then error out with
> OpenSCAP Error: Selector ID(ensure_logrotate_activated) does not exist
> in Benchmark. [xccdf_policy.c:1904] Selector
> ID(service_postfix_enabled) does not exist in Benchmark.
> [xccdf_policy.c:1904]
> So I went back to the oscap I compiled which didn't give any errors
> but every check gave a "Result: notapplicable". I compiled with:
> ./configure --enable-cce --enable-sce
> so I still don't know what I'm doing wrong. Any ideas?

The .tar.gz of SSG you mentioned is well over 18 months old. Mind sharing 
where you nabbed it (the link should probably be taken down)?

Are you able to use the latest SSG RPM? Download instructions at:
scap-security-guide mailing list
scap-security-guide at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5605 bytes
Desc: not available
URL: <>

More information about the scap-security-guide mailing list