Shaw, Ray V CTR USARMY ARL (US) at
Mon May 12 19:14:37 UTC 2014

Classification: UNCLASSIFIED
Caveats: NONE

My results were...interesting.  I ran make in the latest git tree to generate 
a zip file, then got the following error when attempting to import it from the 
command line:

bash-4.1# ./cscc -is /home/username/
Stream ssg-ocilrefs-rhel6- is not a valid stream, therefore will not be 

None of the content appeared in the menus.  However, when I imported it using 
the GUI, it accepted the content, and I was able to proceed with the remaining 
steps.  They seem very similar to what I've been doing in the GUI, so I wasn't 
surprised when I got similar scan results:

bash-4.1# ./cscc

*                      SCAP Compliance Checker (SCC) 3.1.2 
*                                 Developed By 
*                        SPAWAR Systems Center Atlantic 

Stream Version :0.9

HOSTNAME.EXAMPLE.COM: Loading ssg-rhel6-cpe-oval.xml
[ERROR] Invalid content.  No OVAL object value found for package 'NAME'.
    Target System:       HOSTNAME.EXAMPLE.COM
    Selected Profile:    stig-rhel6-server-upstream
    Stream Name:         ssg-rhel6-
    Stream Version:      0.9
    Stream Date:         2014-05-12
    SCAP Stream:         ssg-rhel6
    Profile ID:          stig-rhel6-server-upstream
    Definition ID:       oval:ssg:def:100
    Test ID:             oval:ssg:tst:3135
    Object ID:           oval:ssg:obj:3136
HOSTNAME.EXAMPLE.COM: Loading ssg-rhel6-cpe-dictionary.xml
HOSTNAME.EXAMPLE.COM: The SCAP content stream <ssg-rhel6-> is not applicable 
to this platform per the CPE definitions

Total Errors: 1
Total Warnings: 0
Review complete.
Results, if any, are located in the following directory:

Logs, if any, are located in the following directory:

Ray Shaw (Contractor, STG)
Army Research Laboratory
CIO, Unix Support

> -----Original Message-----
> From: scap-security-guide-bounces at [mailto:scap-
> security-guide-bounces at] On Behalf Of Shawn Wells
> Sent: Monday, May 12, 2014 12:34 PM
> To: scap-security-guide at
> On 5/9/14, 9:28 AM, Shaw, Ray V CTR USARMY ARL (US) wrote:
> > Classification: UNCLASSIFIED
> > Caveats: NONE
> >
> > I remember that there were issues with the SSG content and RHEL6 (due
> > to SCC not supporting a sufficient version of...XCCDF?  SCAP?).  But
> > previously, I could still use SCC with the SSG content; it would just
> > generate a few more false positives than using OpenSCAP.  Admittedly,
> > it has been a while since I tried.
> >
> > Now, when trying SCC 3.1.2, I can't make it run at all.  After
> > importing the zip file (generated from git) and selecting the
> > stig-rhel6-server-upstream profile, a scan finishes almost
> immediately with:
> >
> > 	The SCAP content stream <ssg-rhel6-> is not applicable to this
> > platform per the CPE definitions
> >
> > I've tried on both RHEL6 Workstation and Server, and I've also tried
> > stripping the <platform> information from the XML files.
> >
> > I'm attempting this for two reasons, as otherwise I'm perfectly happy
> > scanning with OpenSCAP.  SCC has the ability to run a check on a
> > single rule at a time, which is useful.  Also, I have an inspection
> > soon, and they may want me to use it.
> Through feedback and active dialog with SPAWAR, we wrote a quick "SCC
> Usage" guide back in Nov 2013 [1]. Could you give it a skim, and if
> you're still having problems, I'll download a copy of the latest SCC
> and see if I can duplicate. The existing docs were written against SCC
> 3.1 RC2, so in theory there should be minimal differences against the
> GA
> release:
> guide/docs/User_Guide/tmp/en-US/html-single/#sect-User_Guide-Alt_Tools-
> [1]
> November/004468.html
> _______________________________________________
> scap-security-guide mailing list
> scap-security-guide at

Classification: UNCLASSIFIED
Caveats: NONE

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5621 bytes
Desc: not available
URL: <>

More information about the scap-security-guide mailing list