rhq-agent keep crashing

Henon Guillaume guillaume.henon at volvo.com
Fri Jun 25 13:58:48 UTC 2010


I have removed lots of plugins, especially ones you mentionned. Agent in now working fine, thanks. I will try to go deeper into it soon.

Anyway, my main goal is to manage jboss and postgres from rhq. Unfortunatly the autodiscovery failed
2010-06-25 15:49:42,336 INFO  [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Process scan auto-detected new server resource: scan=[ProcessScan: query=[process|basename|match=^(postgres|postmaster)$,process|basename|nomatch|parent=^(postgres|postmaster)$], name=[unix]], discovered-process=[process: pid=[25908], name=[postgres], ppid=[1]]
2010-06-25 15:49:42,360 INFO  [ResourceDiscoveryComponent.invoker.daemon-2] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- Discovered a postgres process: ProcessScanResult: scan=[ProcessScan: query=[process|basename|match=^(postgres|postmaster)$,process|basename|nomatch|parent=^(postgres|postmaster)$], name=[unix]], info=[process: pid=[25908], name=[postgres], ppid=[1]]
2010-06-25 15:49:42,360 ERROR [ResourceDiscoveryComponent.invoker.daemon-2] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- Unable to obtain data directory for postgres process with pid 25908 (tried checking both -D command line argument, as well as PGDATA environment variable).

I've tried to put PGDATA environment variable into rhq-agent-env but not enough. I will look at the plugins source to understand from where the information is seek.


Guillaume HENON
Global I&O - GPM Oracle - Oracle Lyon
Volvo Information Technology                                                                                             
402 avenue Charles de Gaulle                               * phone: +33 (0)
API VNX OA0 002    
Vénissieux Cedex - FRANCE                                  * guillaume.henon at volvo.com 

-----Original Message-----
From: rhq-users-bounces at lists.fedorahosted.org [mailto:rhq-users-bounces at lists.fedorahosted.org] On Behalf Of John Mazzitelli
Sent: vendredi 25 juin 2010 15:26
To: rhq-users at lists.fedorahosted.org
Subject: Re: rhq-agent keep crashing

OK, looks like its a JNA problem - based on this:

C  [libc.so.6+0x6d83a]  cfree+0x7a
C  [jna331537674748900792.tmp+0x573b]  Java_com_sun_jna_Memory_free+0x1b
j  com.sun.jna.Memory.free(J)V+0
j  com.sun.jna.Memory.finalize()V+4

Its trying to free memory which causes a segfault - most likely its a 
bug in JNA with their native memory management code. As Ian said, the 
only place JNA is used is in certain plugins (the agent core does not 
use JNA native stuff).

However, you can't purge agent plugins as per Ian's instructions (that 
is only for SERVER side plugins - you can't purge agent plugins today).

If you are using the latest beta, you CAN however DISABLE plugins. See 
this bugzilla issue:


If you are using the latest code, shutdown your agents, disable the 
plugins you don't need that use JNA, then restart your agents and see if 
the problem goes away. I'm not sure of the exact steps here, but I think 
if you shutdown the agents, then disable plugins, then restart agents, 
it should remove those plugins from getting deployed in the agents.

If you track down the JNA bug, let us know and we'll see if we can work 
around it. Perhaps its just an issue where we should upgrade the version 
of JNA we use - if so, we can upgrade that and rebuild the plugins.
rhq-users mailing list
rhq-users at lists.fedorahosted.org

More information about the rhq-users mailing list