[blivet:master 00/25] Yet more pylint fixes

mulhern amulhern at redhat.com
Wed Apr 16 21:54:21 UTC 2014


A mere 100 warning and errors left to go!

mulhern (25):
  Setting variables in __init__
  Import name 'deviceaction' where needed
  Remove addKeyFromFile() method
  Remove suite() methods in tests
  Do not evaluate % operator in log message arguments
  Make signature of Size.__str__ match signature of Decimal.__str__
  Override resize() method in subclasses of StorageDevice
  Suppress W0201 errors
  Add to false positives an error which is not suppressed by a pragma.
  Suppress W0201 error where attribute is set in __new__.
  Do not cache the DeviceFormat object
  Disable E1003 warning.
  Spell BootLoaderError properly
  Remove BootLoaderError definitions
  Suppress W0602 false positives
  Add a stub function for get_bootloader
  Suppress W0621 warnings
  Suppress W0612 (unused-variable) false positives
  Use isResize in isShrink and isGrow.
  Disable E1101 (no-member) error
  Do not use strip() incorrectly
  Put module level code in a method
  Rename to avoid conflict with name in outer scope.
  Rename bits() to numBits()
  Do not assign result of evaluating EddTestFS() to a variable

 blivet/__init__.py                   | 15 +++++++++------
 blivet/arch.py                       |  9 ++++-----
 blivet/deviceaction.py               |  7 +++++--
 blivet/devicefactory.py              |  6 ++----
 blivet/devicelibs/lvm.py             |  6 +++---
 blivet/devices.py                    | 35 ++++++++++++++++++++++++++++++-----
 blivet/devicetree.py                 |  7 ++++---
 blivet/formats/__init__.py           |  3 +++
 blivet/formats/fs.py                 |  2 +-
 blivet/formats/luks.py               | 16 ----------------
 blivet/formats/swap.py               |  1 +
 blivet/partitioning.py               |  2 +-
 blivet/pyudev.py                     | 15 ++++++++-------
 blivet/size.py                       |  2 +-
 blivet/util.py                       |  9 +++++----
 tests/action_test.py                 |  5 -----
 tests/devicefactory_test.py          |  4 ----
 tests/devicelibs_test/btrfs_test.py  |  7 -------
 tests/devicelibs_test/crypto_test.py |  4 ----
 tests/devicelibs_test/edd_test.py    | 20 ++++++++++----------
 tests/devicelibs_test/lvm_test.py    |  6 ------
 tests/devicelibs_test/mdraid_test.py |  7 -------
 tests/devicelibs_test/raid_test.py   |  3 ---
 tests/devicelibs_test/swap_test.py   |  5 -----
 tests/devices_test.py                |  4 ----
 tests/formats_test/init_test.py      |  3 ---
 tests/formats_test/selinux_test.py   |  5 -----
 tests/partitioning_test.py           |  5 -----
 tests/pylint/pylint-false-positives  | 16 ++++++++++++++++
 tests/sanity_check_test.py           |  3 ---
 tests/size_test.py                   |  3 ---
 tests/tsort_test.py                  |  6 ------
 32 files changed, 103 insertions(+), 138 deletions(-)

-- 
1.8.3.1



More information about the anaconda-patches mailing list