[master] Last refactorization set for the Custom spoke

Vratislav Podzimek vpodzime at redhat.com
Mon Apr 14 16:03:15 UTC 2014


With these, I'm done with the refactorization of the code and I will jump on ~8
bugs I've identified when testing my changes.

Vratislav Podzimek (9):
  Refactor out the code for adding device/mountpoint into a method
  Use the @ui_storage_logged decorator for the _destroy_device method
  Refactor out the code for removing empty parents
  Split complex conditions into multiple lines with named parts
  Give an opaque condition a better name explaining its real meaning
  Switch the condition in long if-else statement
  Refactor the btrfs magic into a separate method
  Make the _resolve_btrfs_restrictions method's code nicer
  Give include_btrfs variable a better name

 pyanaconda/ui/gui/spokes/custom.py | 447 +++++++++++++++++++------------------
 1 file changed, 230 insertions(+), 217 deletions(-)

-- 
1.9.0



More information about the anaconda-patches mailing list