[blivet:master 00/12] Patches re calculating size of a raid array

mulhern amulhern at redhat.com
Fri Apr 11 16:27:35 UTC 2014


Besides the original 11 patches, I've added a patch that I believe fixes
a bug in the calculation of the array size.

mulhern (12):
  Make RAIDLevels iterable (#1085474)
  Improve comments on a few methods (#1085474)
  Rename _get_size to _trim, which describes its function better
    (#1085474)
  Rename get_raw_array_size to get_net_array_size (#1085474)
  Log if there was a failure to calculate the size of the
    MDRaidArrayDevice (#1085474)
  Check whether type is mdbiosraidarray before checking smallest member
    (#1085474)
  Move line that might throw an MDRaid exception inside try block
    (#1085474)
  Add a size() method to the raid classes (#1085474)
  Use raid.size method to get size of device (#1085474)
  Remove unused get_size method (#1085474)
  Removed some now unused methods from devices (#1085474)
  Adjust the available size on each disk using chunk size.

 blivet/devicelibs/mdraid.py        |   5 +-
 blivet/devicelibs/raid.py          | 112 +++++++++++++++++++++++++------------
 blivet/devices.py                  |  56 +++++--------------
 tests/devicelibs_test/raid_test.py |  59 ++++++++++++++++---
 tests/devices_test.py              |  22 --------
 5 files changed, 146 insertions(+), 108 deletions(-)

-- 
1.8.3.1



More information about the anaconda-patches mailing list