[master][PATCH] Let users configure keyboard via anaconda in live installations (#1002533)

Vratislav Podzimek vpodzime at redhat.com
Fri Sep 6 07:16:10 UTC 2013


On Thu, 2013-09-05 at 14:55 -0700, Brian C. Lane wrote:
> On Thu, Sep 05, 2013 at 01:59:30PM +0200, Vratislav Podzimek wrote:
> > Setting up keyboard layouts for both the installation process and the installed
> > system is a complicated and confusing task. Because the default environments
> > don't show the layout indicator and have keyboard configuration hidden in some
> > menus, we may let users configure keyboard layouts via anaconda.
> > 
> > If somebody configures keyboard on their own and the anaconda's configuration
> > for the installed system is different, we should warn them and make them visit
> > the Keyboard spoke to confirm the configuration.
> > 
> > Signed-off-by: Vratislav Podzimek <vpodzime at redhat.com>
> > ---
> >  pyanaconda/flags.py                  |  7 +++++--
> >  pyanaconda/keyboard.py               | 26 ++++++++++++++++++++++++++
> >  pyanaconda/ui/gui/spokes/keyboard.py | 21 ++++++++++++++-------
> >  pyanaconda/ui/gui/spokes/welcome.py  |  4 ++--
> >  4 files changed, 47 insertions(+), 11 deletions(-)
> > 
> > diff --git a/pyanaconda/flags.py b/pyanaconda/flags.py
> > index 07e5e95..e79f502 100644
> > --- a/pyanaconda/flags.py
> > +++ b/pyanaconda/flags.py
> > @@ -180,16 +180,19 @@ class BootArgs(OrderedDict):
> >                  result = False # XXX: should noarg=off -> True?
> >          return result
> >  
> > -def can_touch_runtime_system(msg):
> > +def can_touch_runtime_system(msg, ignore_live=False):
> >      """
> >      Guard that should be used before doing actions that modify runtime system.
> >  
> >      :param msg: message to be logged in case that runtime system cannot be touched
> > +    :type msg: str
> > +    :param ignore_live: whether to ignore liveCD installations (can touch liveCD system)
> > +    :type ignore_live: bool
> >      :rtype: bool
> 
> I would name it touch_live instead, makes it clearer when looking at the
> call.
That sounds good, thanks. I was thinking about the name of the parameter
for quite a while. Fixing locally.

-- 
Vratislav Podzimek

Anaconda Rider | Red Hat, Inc. | Brno - Czech Republic



More information about the anaconda-patches mailing list