[PATCH 2/2] DNFPayload: install DNF itself.

Vratislav Podzimek vpodzime at redhat.com
Mon Oct 7 08:11:50 UTC 2013


On Fri, 2013-10-04 at 10:14 -0700, Brian C. Lane wrote:
> On Mon, Sep 30, 2013 at 04:45:04PM +0200, akozumpl at redhat.com wrote:
> > From: Ales Kozumplik <ales at redhat.com>
> > 
> > It's not in any comps yet but testers of the payload will expect it to be
> > present.
> > ---
> >  pyanaconda/packaging/dnfpayload.py | 1 +
> >  1 file changed, 1 insertion(+)
> > 
> > diff --git a/pyanaconda/packaging/dnfpayload.py b/pyanaconda/packaging/dnfpayload.py
> > index 7ee3344..4af95de 100644
> > --- a/pyanaconda/packaging/dnfpayload.py
> > +++ b/pyanaconda/packaging/dnfpayload.py
> > @@ -124,6 +124,7 @@ class DNFPayload(packaging.PackagePayload):
> >          map(self._install_package, self._required_pkgs)
> >          map(self._select_group, self._required_groups)
> >          self._select_kernel_package()
> > +        self._install_package('dnf')
> 
> Does the order matter? If not, I'd rather see this added to
> self._required_pkgs at some point, either in preInstall or maybe as a
> default and then change preInstall to append to the list.
> 
> I also notice that some of the variable naming is different from yumpayload.py
> 
> For example, dnf is using:
> 
> self._required_groups = []
> self._required_pkgs = []
> 
> and yumpayload uses:
> 
> self._requiredPackages = []
> self._requiredGroups = []
> 
> It would be nice if we could use the same names where the functionality
> is the same between the packaging modules.
I'd rather see names following python variable-naming conventions in new
code. Otherwise we would end up with ugly variable names for no reason
once we drop yumpayload.

-- 
Vratislav Podzimek

Anaconda Rider | Red Hat, Inc. | Brno - Czech Republic



More information about the anaconda-patches mailing list