On 02/27/18 17:04, François Patte wrote:
Le 25/02/2018 à 19:42, François Patte a écrit :

I try to configure a printer on my local network but all attemps fail.

I have a printer attached to one computer on an usb port and I want to
use it with other computers on my local network.

I opened firefox on one computer and miracle: the printer attached to
the other computer is discovered and cups admin interface asks me if I
want to add this printer. Nice: the job is easy!! *But* this does not
work at all!!

Sending a test page returns that the printer is not responding.

I tried to cofigure the printer using the "Add printer" way and chose
ipp. According to the given syntax, I wrote: ipp://name-of-server/ipp
but this does not work: sending a test page returns that the printer is
misconfigured or no longer exists...

I replaced the name of the server by its IP address... same result.

I tried: ipp://name-of-server:631/printers/name-of-printer-on-server. It
does not work, the message is now: Filter failed.

What fiter? I don't know as cups logs no longer exist since systemd...

Does somebody know a solution?
After googleling a lot I could solve my problem but in a very strange way!

First I found some people talking about the impossibility to use the
same driver on the server (the computer to which the printer is plugged)
and the other computers on the LAN, them claimed that the driver to use
on the clients must be the "raw" driver. So I tried to modify the
configuration on a client, changing the driver to raw, but cups refuses
at the end to modify the config and I had to delete the printer on the
client and to re-add the printer from scratch using the raw driver and
cups accepted this way of doing.

But printing a test page failed. "Filter failed" was the error!
journalctl gives useless information, just a joke (maybe): " Job stopped
due to filter errors; please consult the error_log file for details."
There is no more error_log file....

At last I tried to use the "automatic way": ask cups to find the
printers on the LAN and add the computer. Using this way, I chose the
raw driver (cups accepted this) but the configuration failed one more
time: "the printer is misconfigured or no longer exists".

So, I asked to modify this configuration, replacing the dnssd address by
an ipp one and I did not change the driver in this modification and,
this time, cups accepted the modification and at last the printer worked!

cups really sucks!

The cups system in Fedora 27 has taken a giant step backward from prior versions in that browsing no longer works automatically.  In F26, if the cups-browsed service was enabled and started, all the printers on the LAN would be discovered and be available for use - automatically.
In F27 this no longer works.  But there is a workaround.

I must now edit /etc/cups/cups-browsed.conf on each and every client machine to add these lines:
     BrowsePoll datium
     BrowsePoll datair
     LocalQueueNamingRemoteCUPS RemoteName

where datium and datair are _my_ servers with connected printers.  Note that Fully Qualified Names, such as datium.datix.lan, are NOT acceptable.  With only two physical printers and a handful of client machines on my LAN, this is marginally tolerable;  with a much larger LAN, it isn't.

I've complained in https://bugzilla.redhat.com/show_bug.cgi?id=1518415 and in https://bugzilla.redhat.com/show_bug.cgi?id=1525937.
Apparently the "upstream" developers have a much different view than me of why Linux printing has traditionally been so successful and reliable and are hell-bent on "fixing" it.
	David A. De Graaf    DATIX, Inc.    Hendersonville, NC
	dad@datix.us         www.datix.us