Sorry, I missed that line when I cut and pasted the config file.  It is there

Robert Marcano wrote:
On Mon, 2004-02-02 at 15:54, David Miller wrote:

I recently "upgraded" from RedHat 9 to Fedora.
I have always used lprng.  I was very disapointed to find that it was 

I have tried to share the printers that I have on my linux box.  I have 
4 windows machines that use my printers.  I have an Hp dj600 and an 
Epson C80 on the linux box.
I have never had any problems shareing them with lprng and samba.

After installing Fedora I learned that I had to use CUPS.  I could make 
my printers work on the linux machine but the windows machines could not 
print.  They would show up in windows explorier but not in the list when 
you would add a network printer.  Nothing I tried seamed to work until I 
ran across a posting via a web search that indicated a problem in samba 
3.0 and it worked with an earlier version of samba. I uninstalled samba 
and downloaded the samba rpms for samba-2.2.7-5.8.0.  I think the samba 
files used in RedHat 8.0.

Now my HP works fine.
On the windows machines, when you say add printer and select network and 
browse you see both printers and installs for both seam to work. The 
Epson still won't print.
In printer configuration both printers are shared. Both work on the 
linux box.


Try adding the printing variable to the global section:

printing = cups

>From the smb.conf man page

"printing (S)
              This parameters  controls  how  printer  status
information is interpreted  on  your system. It also affects the default
values for the print command, lpq command, lppause command, lpresume
command, and lprm command if specified in the [global] section."

you need to use both "printcap" and "printing"

Samba Config is as follows:
   workgroup = HOME
  server string = Samba Server
  printcap name = cups
   load printers = yes
   log file = /var/log/samba/%m.log
   max log size = 0
   security = user
   encrypt passwords = no

   obey pam restrictions = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   remote browse sync =
   os level = 33
   preferred master = yes
   wins support = yes
   dns proxy = no

   comment = Home Directories
   browseable = no
   writable = yes
   valid users = %S
   create mode = 0664
   directory mode = 0775

   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = no
   writable = no
   printable = yes
   use client driver = yes

    path = /var/data/win95
    guest ok = yes
    writeable = yes
    printable = no
    write list = david, cheryl, laniece, cathy, mark
    create mask = 0664
    directory mask = 0775

mime.convs has the following line uncommented:
 application/octet-stream    application/vnd.cups-raw    0    -

mime.types has the following line uncommented:

cups error log still indicates the following when I try to print to the C80;
E [02/Feb/2004:12:13:22 -0600] print_job: Unsupported format 
I [02/Feb/2004:12:13:22 -0600] Hint: Do you have the raw file printing 
rules enabled?

No errors printing to the HP.

There is no entry that shows up in the print queue.

If anyone has any ideas please let me know.

David Miller