tnx for your reply.

Pyorbital cannot be installed via dnf (I didn't find any rpm in the repos). But this doesn't solve the issue of having pyorbital listed in help()/modules and not listed in pip3 list.
Others issues seems to have been solved

Antonio Montagnani

Linux Fedora 27(Workstation)
da/from Gmail

2018-01-23 22:35 GMT+01:00 Jeandet Alexis <alexis.jeandet@member.fsf.org>:
Hi,

I would advise to avoid as much as possible doing "pip install" prefer first dnf then virtualenv and if you really want "pip install --user something"
But never, never, never do 'sudo pip install someting'!

best regards,
Alexis.
On Tue, 2018-01-23 at 20:42 +0100, Antonio M wrote:
installing the zeromq-devel package didn't solve the problem, but dnf reinstall zeromq* seems to have solved it.

Now I have two questions:

1)/usr/lib64/python3.6/site-packages/matplotlib/cbook.py:136: MatplotlibDeprecationWarning: The matplotlib.delaunay module was deprecated in version 1.4. Use matplotlib.tri.Triangulation instead.
  warnings.warn(message, mplDeprecation, stacklevel=1)   what does it mean (that is quite clear to me) but how can I clear it??

2) why pyorbital is in the list from help()/modules but is not present in
[antonio@fujitsu ~]$ pip3 uninstall pyorbital
Cannot uninstall requirement pyorbital, not installed

Tnf forhelp


Antonio Montagnani

Linux Fedora 27(Workstation)
da/from Gmail

2018-01-23 19:08 GMT+01:00 Rick Stevens <ricks@alldigital.com>:
On 01/23/2018 09:49 AM, Antonio M wrote:
> python-devel installed and then....
>
> help> modules
>
> Please wait a moment while I gather a list of all available modules...
>
> /usr/lib64/python3.6/site-packages/matplotlib/cbook.py:136:
> MatplotlibDeprecationWarning: The matplotlib.delaunay module was
> deprecated in version 1.4. Use matplotlib.tri.Triangulation instead.
> warnings.warn(message, mplDeprecation, stacklevel=1)
> Assembler messages:
> Fatal error: can't create
> /usr/lib64/python3.6/site-packages/zmq/backend/cffi/__pycache__/usr/lib64/python3.6/site-packages/zmq/backend/cffi/__pycache__/_cffi_ext.o:
> Permission denied
> /usr/lib64/python3.6/site-packages/zmq/backend/cffi/__pycache__/_cffi_ext.c:212:10:
> fatal error: zmq.h: No such file or directory
> #include <zmq.h>
> ^~~~~~~
> compilation terminated.
> Assembler messages:
> Fatal error: can't create
> /usr/lib64/python3.6/site-packages/zmq/backend/cffi/__pycache__/usr/lib64/python3.6/site-packages/zmq/backend/cffi/__pycache__/_cffi_ext.o:
> Permission denied
> /usr/lib64/python3.6/site-packages/zmq/backend/cffi/__pycache__/_cffi_ext.c:212:10:
> fatal error: zmq.h: No such file or directory
> #include <zmq.h>
> ^~~~~~~
> compilation terminated.

You need to install the zeromq-devel RPM. A "dnf whatprovides */zmq.h"
would reveal that.
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer, AllDigital    ricks@alldigital.com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-       "I'd explain it to you, but your brain might explode."       -
----------------------------------------------------------------------
_______________________________________________
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-leave@lists.fedoraproject.org

_______________________________________________
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-leave@lists.fedoraproject.org

_______________________________________________
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-leave@lists.fedoraproject.org