On Tue, Oct 27, 2015 at 8:30 PM, stan <stanl-fedorauser@vfemail.net> wrote:
On Tue, 27 Oct 2015 20:06:09 -0700
Dave Johansen <davejohansen@gmail.com> wrote:

> On Tue, Oct 27, 2015 at 8:47 AM, stan <stanl-fedorauser@vfemail.net>
> wrote:
> > On Sun, 25 Oct 2015 20:03:18 -0700
> > Dave Johansen <davejohansen@gmail.com> wrote:
> >
> > > I recently did a clean install of F22 Mate Spin from F21 and
> > > sound is no longer working. I tried the recommendations from
> > > https://fedoraproject.org/wiki/How_to_debug_sound_problems but
> > > nothing seemed to work. Is there anything else I should try?
> >
> > Run  aplay -lv  to see if alsa found your sound devices.
> >
> I don't really know what to expect, but this looks fine to me:
>  $ aplay -lv
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: AD1981 Analog [AD1981 Analog]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> card 0: Intel [HDA Intel], device 1: AD1981 Digital [AD1981 Digital]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> Install pavucontrol and check how pulseaudio has configured those
> sound
> > devices.  You might have defaulted to an invalid default device,
> > like the hdmi on a video device.  Set everything how you want it.
> >
> Nothing seemed out of the ordinary for this and sound still doesn't
> work. Any other suggestions?

Bring up pavucontrol and remove device 0 from pulsaudio control.
Should be on the last tab.  Then check what happens if you try to play
a .wav file with the command
aplay --device=plughw:0,0  some_wav_file.wav
If it plays, the problem is in the pulseaudio setup / interface with
alsa, because alsa is working, so the correct driver is loaded
and working.
If it seems to be working, but there is no sound, check physical
connections like speakers, because alsa thinks its sending sound to

aplay doesn't error out or anything but there's no sound. It's a T60 laptop so I don't know how I can check connections.
If the command aborts, then there is a problem with the alsa driver.
That seems unlikely, since aplay showed it correctly.

If you have audacity installed, you can confirm the failure by
importing a sound file into audacity (File->audio_import), and playing
it (space bar). If the meters move, but there is no sound, then the
driver is loaded and functioning, but there is a disconnect at output.

If all the connections are right, it might be that the default device
is device 0,1 (digital), instead of device 0,0 (analog).

I tried device 0,1 and device 0,0 and neither worked.