could you please help me with this problems. We have several computers running Fedora Core 1. All of them were working perfectly for some time (several months). Then last week two of them stopped booting. They start booting and then stop after message Enabling swap space. All the computers have the same fixed configuration running just plain Fedora with one custome application. After analyzing user's behaviour we think it may have something to do with use of USB key. Our users plug in USB key to transfer some data. The only commong behaviour we could identify was that if the users removed the key during shutdown or sometimes plugged it in during startup it rendered the computer unbootable.

We have tried everything, the computers don't have plugged in any peripheral, only keyboard and mouse (and we tried even without eyboard and mouse) but they will not boot anymore.

Can anybody advice me how to troubleshoot this? I would like to know if I can find out what is causing the problems or how can make the computers boot again to get to the data and make them usable again. Reinstall is not an option since as I said, the computers have fixed configuration and nothing but the data changes on them so nothing should be different from those working computers. Is there any explanation how can this happen? Any help would be really appreciated.