Greetings All:

I am having problems with this package from fc17 x86_64, and iIt is stopping too many things from being updated...

If I download the latest package from koji and do an:
rpm -Uvh --force --no deps cogl*, it will do an update for that package because I am forcing it...  Once I do this though, than yum is screwed up and I can no longer run yum!

Here is the dependencies error that I get on my terminal...

[root@localhost dummy]# yum update
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rpmfusion-free-rawhide: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-rawhide: mirrors.cat.pdx.edu
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package cheese.x86_64 1:3.1.91.1-1.fc16 will be updated
---> Package cheese.x86_64 1:3.1.92-2.fc17 will be an update
---> Package cheese-libs.x86_64 1:3.1.91.1-1.fc16 will be updated
---> Package cheese-libs.x86_64 1:3.1.92-2.fc17 will be an update
---> Package clutter.x86_64 0:1.7.14-2.fc16 will be updated
---> Package clutter.x86_64 0:1.8.0-1.fc17 will be an update
---> Package clutter-gtk.x86_64 0:1.0.2-2.fc16 will be updated
---> Package clutter-gtk.x86_64 0:1.0.2-4.fc17 will be an update
---> Package cogl.x86_64 0:1.7.8-1.fc16 will be updated
--> Processing Dependency: libcogl.so.2()(64bit) for package: libmx-1.3.1-1.fc16.x86_64
--> Processing Dependency: libcogl.so.2()(64bit) for package: clutter-gst-1.3.14-1.fc16.x86_64
--> Processing Dependency: libcogl.so.2()(64bit) for package: sushi-0.1.90-1.fc17.x86_64
--> Processing Dependency: libcogl.so.2()(64bit) for package: gnome-shell-3.1.91.1-2.fc17.x86_64
--> Processing Dependency: libcogl.so.2()(64bit) for package: libmash-0.2.0-1.fc17.x86_64
---> Package cogl.x86_64 0:1.8.0-1.fc17 will be an update
---> Package gnome-shell.x86_64 0:3.1.91-2.fc16 will be updated
---> Package gnome-shell.x86_64 0:3.1.91.1-2.fc17 will be an update
---> Package libchamplain.x86_64 0:0.10.0-4.fc16 will be updated
---> Package libchamplain.x86_64 0:0.12.0-1.fc17 will be an update
---> Package libchamplain-gtk.x86_64 0:0.10.0-4.fc16 will be updated
---> Package libchamplain-gtk.x86_64 0:0.12.0-1.fc17 will be an update
---> Package libmash.x86_64 0:0.1.0-2.fc16 will be updated
---> Package libmash.x86_64 0:0.2.0-1.fc17 will be an update
--> Processing Dependency: libcogl.so.2()(64bit) for package: libmash-0.2.0-1.fc17.x86_64
---> Package mutter.x86_64 0:3.1.91.1-1.fc16 will be updated
---> Package mutter.x86_64 0:3.1.92-1.fc17 will be an update
---> Package sushi.x86_64 0:0.1.90-1.fc16 will be updated
---> Package sushi.x86_64 0:0.1.90-1.fc17 will be an update
---> Package totem.x86_64 1:3.1.4-1.fc16 will be updated
---> Package totem.x86_64 1:3.1.92-1.fc17 will be an update
---> Package totem-mozplugin.x86_64 1:3.1.4-1.fc16 will be updated
---> Package totem-mozplugin.x86_64 1:3.1.92-1.fc17 will be an update
---> Package totem-nautilus.x86_64 1:3.1.4-1.fc16 will be updated
---> Package totem-nautilus.x86_64 1:3.1.92-1.fc17 will be an update
--> Finished Dependency Resolution
Error: Package: libmash-0.2.0-1.fc17.x86_64 (rawhide)
           Requires: libcogl.so.2()(64bit)
           Removing: cogl-1.7.8-1.fc16.x86_64 (@fedora/16)
               libcogl.so.2()(64bit)
           Updated By: cogl-1.8.0-1.fc17.x86_64 (rawhide)
               Not found
Error: Package: sushi-0.1.90-1.fc17.x86_64 (rawhide)
           Requires: libcogl.so.2()(64bit)
           Removing: cogl-1.7.8-1.fc16.x86_64 (@fedora/16)
               libcogl.so.2()(64bit)
           Updated By: cogl-1.8.0-1.fc17.x86_64 (rawhide)
               Not found
Error: Package: libmx-1.3.1-1.fc16.x86_64 (@fedora/16)
           Requires: libcogl.so.2()(64bit)
           Removing: cogl-1.7.8-1.fc16.x86_64 (@fedora/16)
               libcogl.so.2()(64bit)
           Updated By: cogl-1.8.0-1.fc17.x86_64 (rawhide)
               Not found
Error: Package: gnome-shell-3.1.91.1-2.fc17.x86_64 (rawhide)
           Requires: libcogl.so.2()(64bit)
           Removing: cogl-1.7.8-1.fc16.x86_64 (@fedora/16)
               libcogl.so.2()(64bit)
           Updated By: cogl-1.8.0-1.fc17.x86_64 (rawhide)
               Not found
Error: Package: clutter-gst-1.3.14-1.fc16.x86_64 (@fedora/16)
           Requires: libcogl.so.2()(64bit)
           Removing: cogl-1.7.8-1.fc16.x86_64 (@fedora/16)
               libcogl.so.2()(64bit)
           Updated By: cogl-1.8.0-1.fc17.x86_64 (rawhide)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

--
Sincerely yours,
Rob G. Healey

"Always surround yourself with people that inspire you to
greatness!"