Several things.    Some backgroun -- in our company, we have thousands of OL8.x and hundreds of RHEL 8.x Linux servers directly AD integrated to our corp AD domain.

I compared our sssd.conf with yours.  I think you want to add the 'ifp' service for *L8.  It's the infopipe service.  Used by support utilities such as sssctl domain-list, etc.

I thought you had to have a sssd.conf stanza for each service you enable.  For instance, we have this:

debug_level = 0x0100
#debug_level = 9
filter_groups = root
filter_users = root

pam_verbosity = 3
#debug_level = 9
offline_credentials_expiration = 3


Because we have 
services = nss,pam,ifp

From your ldap_child.log, it looks like your SASL bind and then the LDAP query is working.  Which is surprising to me.  We set up

ldap_sasl_authid = host/<fqdn>@<ad domain>

in our sssd.conf file.  But I'm guessing if that's not explicitly set, it uses HOSTNAME$@REALM.  At least that's what it appears from your ldap_child.log. It appears to use:  TEST0003$

Several things to try to narrow down where the failure is occuring.  
1. try 'kinit -k'  on the command line.   That uses the first entry in /etc/krb5.keytab file to attempt to authenticate as this machine account.  It's not a perfect test, since it's acquiring a TGT ticket instead of a service ticket.
2. If that succeeds, try kvno -S host TEST0003
     That should report the KVNO of your machine account credentials, as stored in AD.  This is a better test, as you're acquiring a service ticket here.  (Like sssd does).
3. Try 'adcli testjoin -D -v'.  This tests the sssd connectivity, similar to how sssd does it.

if all that works, your problem is not with LDAP or your SASL binding.  So then,

4. try 'getent passwd'.  That should return the entry for this user.  If this fails, possibly your /etc/nsswitch.conf file isn't set up right or maybe your attribute mapping in AD isn't agreeing with your sssd.conf setting.  (We use the MS-supported RFC2307bis AD schema extension)..

5. If that's good, then probably the problem is something in your PAM stack.  Specifically, the auth phase.   In our /etc/pam.d/sshd file, we have:

auth       substack     password-auth
auth       include      postlogin

and in password-auth, we have:

auth        required                           
# OL7/8 version. Per I/T's stated policy for service & process accounts, lock-out time = 30 mins
auth        required                            preauth silent deny=5 unlock_time=1800
auth        sufficient                          forward_pass
auth        sufficient                          nullok try_first_pass
auth        requisite                           uid >= 1000 quiet_success
auth        required                            authfail deny=5 unlock_time=1800
auth        required                           


On Thu, Nov 18, 2021 at 7:16 AM Aron Kelemen Szabo <> wrote:



We are trying to join a RHEL8.4-server to our Active Directory with the realm name


Our first attempt was to follow the RedHat-guide ( to join RHEL8.4 to an AD, also covering the installation and configuration of SSSD and the machine seem to have got joined to the AD (the computer account appears and both adcli info as well as the id commands return valid lookup-results from the Active Directory)… The TGT also seems to be fetched successfully.


However, we cannot log on to the system with any AD-account and /var/log/sssd/krb5_child.log contains the errors below (please view the attached log-files for a complete log-listing), hitting the critical failure (SSSDBG_CRIT_FAILURE), emitting the internal error “[111][Connection refused]” already at the call to the function krb5_cc_cache_match(), called from the function create_ccache():


(2021-11-18 11:02:16): [krb5_child[3585]] [sss_send_pac] (0x0080): failed to contact PAC responder

(2021-11-18 11:02:16): [krb5_child[3585]] [validate_tgt] (0x0040): sss_send_pac failed, group membership for user with principal [aron.kelemen\@OURLAB.SE@OURLAB.SE] might not be correct.

(2021-11-18 11:02:16): [krb5_child[3585]] [sss_child_krb5_trace_cb] (0x4000): [3585] 1637229736.192904: Destroying ccache MEMORY:rd_req2


(2021-11-18 11:02:16): [krb5_child[3585]] [get_and_save_tgt] (0x2000): Running as [285279201][285200513].

(2021-11-18 11:02:16): [krb5_child[3585]] [sss_get_ccache_name_for_principal] (0x4000): Location: [KCM:]

(2021-11-18 11:02:16): [krb5_child[3585]] [sss_get_ccache_name_for_principal] (0x2000): krb5_cc_cache_match failed: [111][Connection refused]

(2021-11-18 11:02:16): [krb5_child[3585]] [create_ccache] (0x0020): 1000: [111][Connection refused]

(2021-11-18 11:02:16): [krb5_child[3585]] [map_krb5_error] (0x0020): 1853: [111][Connection refused]

(2021-11-18 11:02:16): [krb5_child[3585]] [k5c_send_data] (0x0200): Received error code 1432158209

(2021-11-18 11:02:16): [krb5_child[3585]] [pack_response_packet] (0x2000): response packet size: [20]

(2021-11-18 11:02:16): [krb5_child[3585]] [k5c_send_data] (0x4000): Response sent.

(2021-11-18 11:02:16): [krb5_child[3585]] [main] (0x0400): krb5_child completed successfully


Interestingly, the following lines appeared in /var/log/secure when performing the logon-attempt above (with the AD-user kelaro):

Nov 18 13:12:50 test0003 sshd[4183]: pam_sss(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost= user=kelaro

Nov 18 13:12:50 test0003 sshd[4183]: pam_sss(sshd:auth): received for user kelaro: 4 (System error)

Nov 18 13:12:52 test0003 sshd[4183]: Failed password for kelaro from port 54138 ssh2



/etc/sssd/sssd.conf contains the following settings:


domains =

config_file_version = 2

services = nss, pam

default_domain_suffix =



ad_domain =

krb5_realm = OURLAB.SE

debug_level = 10

ad_server =

realmd_tags = manages-system joined-with-samba

cache_credentials = True

id_provider = ad

ad_hostname =

krb5_store_password_if_offline = True

default_shell = /bin/bash

ldap_id_mapping = True

use_fully_qualified_names = True

fallback_homedir = /home/%u@%d

access_provider = ad


We have also tried to:

1. Set krb5_validate to false as well as setting the default_ccache_name = FILE:/tmp/krb5cc_:%{uid} but none of these changes helped either.

2. Set the system crypto-policy from DEFAULT to DEFAULT:AD-SUPPORT (update-crypto-policies --set DEFAULT:AD-SUPPORT) did not help either.

3. Remove the host from the realm (realm leave), deleted it’s computer account from the Active Directory and tried to set it’s hostname as FDQN (hostnamectl set-hostname and then re-joined it again (realm join), but still with the same results…

4. Apply the realm permit --all command, but we could still not log in with our user ( User principal for is aron.kelemen\@OURLAB.SE@OURLAB.SE.

5. Set realmd_tags to “manages-system joined-with-adcli”, but the problem still remained

6. Follow several other similar tutorials (for example to join the host to the AD, however all of them resulted in the same error described here.



The following SSSD and KRB5 package-versions are installed on the host:

















I have also attached the krb5_child.log and ldap_child.log (created with log-level 0x3ff0) after my latest logon-attempt (as the user kelaro).


Any help/tips about:

  1. Why the “Connection refused”-error is being generated of the krb5_cc_cache_match-function
  2. Why the UPN is getting appended to the user name (aron.kelemen@OURLAB.SE@OURLAB.SE despite I have actively attempted to disable this by setting use_fully_qualified_names = False), and whether this can be declared as a fatal condition
  3. Possible failure reasons for sss_send_pac, leading to the “failed to contact PAC responder” error message…

would be greatly appreciated!


Med Vänliga Hälsningar / Best Regards


Áron Kelemen Szabó
IT Data Center Administrator / Linux Engineer

PostNord Strålfors AB


sssd-users mailing list --
To unsubscribe send an email to
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it: