On 28 Mar 2016, at 21:02, Simo Sorce <simo(a)redhat.com> wrote:
While looking at the monitor code I realize we define SSSD_PIDFILE_PATH
in monitor.c in a different way than we define SSSD_PIDFILE in
Although the definitions differ, they end up being effectively the same
string for now.
It seem to me those definition should be merged and harmonized into one.
If not a comment should be put in the code explaining why we have 2
(potentially) different pid file names.
Hints, on which way is right ?
I think the pidfile definitions should be merged and probably using a macro instead of
hardcoded "sssd" is more flexible if we change the PIDfile in the future.. I
don't know why we have two duplicate definitions, maybe Michal remembers? (git blame
points in his direction :-))
Either way, this does sound like a candidate for unification.
Should we open a ticket on this ?
Feel free to.
Simo Sorce * Red Hat, Inc * New York
sssd-devel mailing list