Rowland actually emailed me some nice build instructions that maybe should be on a wiki somewhere?

Also, I'm actually trying to build debs of 1.10.1 since I need the package installed on several machines. I will use Rowland's directions as a starting point for deb-creation documentation.

Are these instructions of interest to anyone? Is there a good repository for these type of instructions is this type of documentation not a priority?



On Wed, Aug 28, 2013 at 10:51 AM, Lukas Slebodnik <> wrote:
On (28/08/13 10:31), Chris Hartman wrote:
>I've been having trouble getting SSSD to compile correctly on Ubuntu 12.04.
>Would you mind listing the commands you used to successfully compile
>1.10.1? I'm assuming you downloaded the tarball from the sssd website?
It should not be problem to compile sssd 1.10.1 on Ubuntu 12.04.
I guess it was a missing dependency.


>On Wed, Aug 28, 2013 at 9:42 AM, Rowland Penny <>wrote:
>> On 28/08/13 14:30, Timo Aaltonen wrote:
>>> On 28.08.2013 12:08, Jakub Hrozek wrote:
>>>> On Wed, Aug 28, 2013 at 09:49:57AM +0100, Rowland Penny wrote:
>>>>> On 28/08/13 09:17, Jakub Hrozek wrote:
>>>>>> On Tue, Aug 27, 2013 at 10:27:55PM +0100, Rowland Penny wrote:
>>>>>>> Hi, I run sssd on Linux Mint 15, I received and installed a raft of
>>>>>>> sssd updates today. I immediately lost the ability to connect to the
>>>>>>> domain.
>>>>>>> The problem was that whilst there was a in /var/run/ ps ax
>>>>>>> didn't show any sssd programs and if you tried to restart sssd, it
>>>>>>> just hung. The machine would not turn off, you had to hold the power
>>>>>>> button to stop it.
>>>>>>> In the end I downloaded 1.10.1 and compiled & installed it over the
>>>>>>> installed sssd, everything now works again.
>>>>>>> Rowland
>>>>>> Sounds like something to bring up in your distribution bug tracker?
>>>>>> What version did you upgrade to (and from) that was broken? Maybe you
>>>>>> hit
>>>>>> some bug that was fixed later.
>>>>>> ______________________________**_________________
>>>>>> sssd-devel mailing list
>>>>>> sssd-devel@lists.fedorahosted.**org<>
>>>>>> https://lists.fedorahosted.**org/mailman/listinfo/sssd-**devel<>
>>>>> Ok, I am not sure what exact ubuntu version of sssd I had, it was
>>>>> 1.9.4-something, Ubuntu issued a raft of sssd updates
>>>>> libipa-hbac-dev     libipa-hbac0     libnss-sss     libpam-sss
>>>>> libsss-idmap0     libsss-sudo     python-libipa-hbac     python-sss
>>>>> sssd-tools
>>>>> I ended up with version 1.9.4-0ubuntu4.2
>>>>> Before the updates, sssd worked perfectly, after the update, sssd
>>>>> did not work at all, my pc hung and when I did get back in as a
>>>>> local user, the domain was not visible. Downloading 1.10.1,
>>>>> compiling and installing over the installed sssd packages cured the
>>>>> problem, so the cause must have been the update.
>>>>> I think the relevant ubuntu bug is 903752, this refers to
>>>>> 'libpwquality' for which a certain 'Timo Aaltonen' provided an
>>>>> update for on the 9/7/2013 and 'Adam Conrad' finally released the
>>>>> fix on 24/8/13, this fix hit my pc on 27/8/13 and made my pc
>>>>> unusable.
>>>>> I do not have an account at ubuntu to report the bug, so I thought
>>>>> that I would cut out the monkeys and come direct to the organ
>>>>> grinder ;-) , could you please get 'Timo Aaltonen' to talk to 'Adam
>>>>> Conrad' and sort out the problem.
>>>>> Thanks
>>>>> Rowland
>>>> I can certainly CC Timo and ask him if this is something that rings a
>>>> bell :-)
>>> First time I hear about this. All the update did was fix a path on the
>>> apparmor profile, assuming you were running 1.9.4-0ubuntu4.1. And I know
>>> nothing about Mint.
>>> 903752 has nothing to do with this, it's just a meta-bug about moving
>>> sssd in the 'main' repository, making it officially supported and
>>> available to the installer and such in the future.
>>>  Hi, all I can say is that about 17:45 GMT yesterday, I allowed a list of
>> sssd updates to go ahead, I use Linux Mint 15 but as this is based on
>> Ubuntu 13.04 the updates came from Ubuntu. I left it to update and when I
>> came back, the screensaver had kicked in and could not get back in. I had
>> to power off the machine by pressing and holding the power button. When I
>> did get the machine to restart, all the domain users had seemingly gone. I
>> finally traced the fault to the fact that sssd had crashed, hung, call it
>> what you will, it had a pid but did not shown in 'ps ax'. I tried to purge
>> sssd but could not, the terminal just hung and in the end I had to power
>> off the computer again. I had to download and install 1.10.1 over the
>> already installed sssd packages, force-ably power off the machine again and
>> restart. Everything now worked just like before the update, ergo it must
>> have been the update that was at fault.
>> Rowland
>> ______________________________**_________________
>> sssd-devel mailing list
>> sssd-devel@lists.fedorahosted.**org <>
>> https://lists.fedorahosted.**org/mailman/listinfo/sssd-**devel<>

>sssd-devel mailing list