On (27/04/16 15:18), Stephen Gallagher wrote:
> On 04/27/2016 05:57 AM, Pavel Březina wrote:
>> On 04/26/2016 05:08 PM, Stephen Gallagher wrote:
>>> Our users constantly make the mistake of typing `debug = 9` in the sssd.conf
>>> instead of `debug_level = 9` as would be correct. This happens
>>> that we should just alias it rather than continue to have people make
>> I don't really oppose but I'd rather print a warning instead of aliasing
>> otherwise we can end up aliasing everything. It may be done as part of
>> configuration check patches that should detect typos.'
> Yeah, I don't want this to become a common thing (we shouldn't really be
> aliasing anything), but this is such a *common* mistake that it's bordering on
> ridiculous not to just make an exception here.
> When you get right down to it, most projects use the more abbreviated term
> "debug" anyway, so we're kind of the outlier.
> (You will notice I intentionally didn't add it to the manual; this is meant to
> be a hidden convenience feature, not the primary method. Also, `debug_level`
> will always overrule `debug` if both are present.)
I don't prefer undocumeted options.
If we really want to have an alias then it should be documented.
Otherwise users might wonder why it magicaly works.
The option/alias will need to be added to the list of valid options anyway
with the config validation (coming soon)
Ok, I added documentation and tests for it. See attached patch.