On Tue, May 01, 2012 at 02:47:34PM -0400, Stephen Gallagher wrote:
> On Wed, 2012-04-25 at 14:52 +0200, Jakub Hrozek wrote:
> > On Tue, Apr 24, 2012 at 11:31:10AM +0200, Jakub Hrozek wrote:
> > > [PATCH] Rename split_service_name_filter
> > > The function was used outside services code which was confusing due to
> > > its name. This patch renames it to sound more netrual.
> > >
> > > [PATCH] SSH: Add dp_get_host_send to common responder code
> > > Instead of using account_info request, creates a new ssh specific
> > > request. This improves code readability and will make the code more
> > > flexible in the future.
> > >
> > > https://fedorahosted.org/sssd/ticket/1176
> > >
> I don't like the construct you added to the "Invalid Filter" section
> be_host_handler(). For one thing, ret is checked without a guarantee it
> has been set (it's set coincidentally further up, but we cannot rely on
> that). For another, it's identical to the handling for when the
> strncmp() fails. Please combine them and make sure that ret is
> initialized properly.
> You're not freeing filter in sss_dp_get_ssh_host_msg() if
> dbus_message_new_method_call() returns NULL.
Thanks, new patches are attached.